-1

Ok. This might be a little long winded but i will try to give as much information as possilbe. I started with Office 2003 and then tried the 2007 Student trial version. When it expired I could not get it to uninstall so I dealt with the annoying problem until my university got the Office Pro Plus 2007 Win 32 version for us students and installed it thinking it would fix the problem. It didn't. So I uninstalled 2007 and 2003, then used a registry cleaner to get rid of all of the old office entries that were dead and left over from the Student Version. Now I am trying to reinstall 2007 Pro and I keep getting the following error before it backs out and quits. It says it cannot find the file Office.en-us\OfficeMUI.msi even though I can find it by exploring the cd. What can I do to make this work for me?

WO

15
Contributors
18
Replies
36
Views
9 Years
Discussion Span
Last Post by Takamura
0

Try this...Create a new folder on your computer's hard drive and then copy the contents of the CD to that folder; now run the setup from the hard drive location.

0

Try this...Create a new folder on your computer's hard drive and then copy the contents of the CD to that folder; now run the setup from the hard drive location.

I tried it as mentioned in the above pocedures I still getting the error message : [office 2007 setup error cannot find Office.en-us\OfficeMUI.msi

0

Thanks for the advice. I had forgot that this thread was still open. Since I had not got an answer for so long I just reinstalled windows and reformatted the hard drive. I never could figure out what the problem was, though.

1

When the setup hangs and asks for the path to "Office.en-us\OfficeMUI.msi", you should not select the "Office.en-us" folder but its PARENT folder (the one containing the folder the setup asks for). Spent hours to figure it out.
Cheers, DM.

0

doesn't work, i had same problem, i am installing to windows 7 and each time i click the parent folder it just moves on to the next "missing file" nothing works. i really am at a loss here, there is no way i am making any kind of noob mistake, the software just doesn't seem to work with windows 7, i tried on 3 different computers, same result. if anyone finds a solution please reply ASAP.
thanks
Brook

0

I'm having the same problem with Office 2010 install on any PC that we've upgraded from Vista to Win7. that's the only common event i can see, but I'm getting the same msi error.

anyone have any experience fixing missing msi files for any other reason?

Thanks for any suggestions, this situation is very annoying...

-Dave Mc.

0

I have a HP Machine that comes preloaded with vista i just formatted everything and installed win 7. Now when i try to install the office 2007 or 2010 same problem comes.
I guess that there is some issue with the Registry,, but have no idea how to go about it.. Anybody Please help all of us..

0

I haven't had a chance to try yet, sorry. will update you when i do.

0

Create a folder on your desktop called "Office.en-us". Find the same folder on the CD and copy "OfficeMUISet" to the folder on your desktop.
Re-insert the CD so that the setup starts again.
When it tells you it cannot find the file and wants you to select a folder, click on DESKTOP.

It takes a minute to get started but it will install just fine.

0

I tried that and it says, "Cannot copy OfficeMUISet: Access is denied. Make sure the disk is not full or write-protected and that the file is not currently in use."

0

i have the same problem , at first time , i have used the default setup path(C:\problem file\microsoft), find the same problem ( cannot find Office.en-us\OfficeMUI.msi),finially , i choose custom option, then choose setup path (D:\problem file \ microsoft), then it is work , problem disappear. i think it is maybe something about write premission of the disk

0

HI GUYS,

I have tried everything everybody suggested just didn't get anywhere.

HOWEVER what i realised is when you click on the folder the setup is asking for... clicking on it tells the setup this is the actual file you're looking for. This is not correct, but what is correct is that the folder contains the file the setup request. No matter how many times you press the plus sign to get to the file required it doesn't show up. however we all know it's in there. so how do you solve this problem.

SIMPLE don't left click on it like you're selecting, right click on it like you would do to get a drop down list. don't select anything from the dropdown list though, RATHER just press ok and the setup will automatically find the file and continue installation!!!

Also don't look for the file just left click the initial folder, so in my case exactly what the first word says "Publisher.en-us"

Please give your views if this worked for you???

Edited by Abu_2

0

another solution:

1) go to folder options and enable the option to view hidden files
2) go to c:
3) you'll see that there is a hidden folder named MSOCache. go into it and press ok when it prompts you that you require permission to view contents of this folder.
5) once you're in the MSOCache folder, dont leave it
6) run your microsoft setup now.

The setup should work just fine now.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.