(NB! This is NOT one of those widely discussed cases described in KB281679)

I am having a major trouble with my home computer. Internet explorer refuses to open links in new window. If a link itself wants to open new window, or I force it do so by shift-clicking, nothing happens. Links will also not open from Outlook Express and MSN. Ordinary links in IE do open just fine, opening new windows with Ctrl-N also works.

The very special thing about this problem is that it only affects users who do not have administrator rights. If I put a user in Administrators group, the problem is completely gone. Remove from Administrators, and problem is back.

I have read KB281679 many times and did everything they said, multiple times, but that didn't solve anything. In fact, the symptoms of my problem are somewhat different, in my case everything else works, including Print preview. I never get error messages or blank windows, and all registry keys mentioned in the article are OK.

I suspect that my trouble came after I got rid of evil CoolWebSearch that sneaked into my computer with MSN Plus. SpySweeper was able to find and remove the bastard, but shortly after that my users started complaining about links not working.

What I did trying to solve it:
- played with "Reset Web Settings" and "Reuse windows for launching shortcuts" - no gain
- created new user profiles - new users have same problem if not an administrator
- ran thru numerous anti-viruses and adware removing tools, with fresh definitions of course - no malware was found
- reinstalled IE6 and Windows SP4 - no gain
- and, last but not least, I have never used any popup blocking software.

What else could I do, reinstall windows? :-|

Wapper

Win2000 SP4
IE60 SP1

I have the same problem, except that it is one machine.

I have two profiles, an admin and a user. The user profile is showing the same symptoms as you describe, AND, some dialog boxes don't display text properly too!

I just tried cresating a new account with an admin profile, and that has the same symptoms too, although the one I use, with an admin profile is fine.

These problem started after I uninstaled .NET, which also caused a load of other stuff, like MS Office not working.

I have followed various other suggestions, like re'regsvr32'ing various dlls without any sucess.

I also did a windiff (file comp utility with visual studio) on the entire registry files from my profile and the not working one. It couldn't find anything (which in itself is strange as I would expect the current user key to have at least SOME differences!)

Did you resolve this problem wapper? Its weird

Nope, I'm still there. Had to add all home users to Administrator group to make them quit whining. BTW, just like you, I compared HKCU branches from different users and found no significant differences.

It seems that something just screwed up my registry. Yesterday I had hard times manually repairing permissions for different keys in HKCR branch. About hundred of keys in Typelib and Interface sections, mostly related to Internet Explorer and Windows Media Player, lost their Owners. A key without owner is completely unusable and is seen as grey row in RegEdt32.exe. So I had to take ownership of each key, AND EACH SUBKEY, and assign inherited permissions. Took me ages to do that. I was hoping that this will also repair my IE to be able to open new windows again, but - no it didn't.

Anyway, I think that there are other errors in registry that are related to security. Unfortunately it is very difficult to track which key is related to my problem. There are utilities like NTRegMon that let you log access of the registry. But NTRegMon doesn't work if you are not an administrator, and if you are, then you don't need the utility because IE is doing fine. Besides, anything you do in Windows causes *tons* of registry accesses and is quite a nightmare to analyze.

The only cause for my problem that I can think of is having SpySweeper eliminate CWS. Or maybe CWS did it, dunno. Anyway, If I am not able to fix the registry, I will purge all traces of IE from my machine and may God have mercy on me!

Wapper

I had the same problem after installing .NET, even within Admin logins i couldnt get IE to open a URL-link coming from an outside program.
Copying the url over to an open instance of IE worked fine.
I tried a few of the solutions out there but a weird one fixed it somehow for me.
I went to Office XP, in Add/Rem programs and option> Repaired it to restore related .dlls i guess.
It seems to have worked.