when on a site I click on a link which opens a new IE, the IE doesn't load up the document, how can I set it up where when I click on a link the document can get opened up in a new window? thanks

Do you mean that you want all links to open up in a new window? I don't think you could set this as default - nor do I see why you'd want to? On the other hand, you can right click on any link and choose "open in new window"

When you click on some links, they go straight to the link without opening up a new IE and some links tend to open up a new IE to show the linked page, well when I click on the ones that have to open up a new IE, and new IE opens but it doesn't show anything on the page. I figured it might be one of my custom level functions but i don't know which, thanks.

The solution to your problem isn't in your browser. The HTML code for the page specifies if the link should be opened in a new window, or not.

Do you have a popup killer that is just horribly written?

try the following:
1) launch IE, go to Tools & then Internet Options;
2) on the General tab (which it launches to) delete cookies and temporary internet files, including all offline content;
3) go to Advanced tab, lower right click on restore defaults and click Apply;
4) go to Programs tab, middle left click on reset web setting, (recommend you deslect reset homepage);
5) go to Privacy tab (if present), if Default Levels button is active click it;
6) go to Security tab and for each zone set levels to Default Levels if said button is active; click OK.
HTH

When you click on some links, they go straight to the link without opening up a new IE and some links tend to open up a new IE to show the linked page, well when I click on the ones that have to open up a new IE, and new IE opens but it doesn't show anything on the page. I figured it might be one of my custom level functions but i don't know which, thanks.

I had to fix this problem as well. I had to

click on Start and select Run. I typed regsvr32 actxprxy.dll then clicked OK. Then I typed regsvr32 shdocvw.dll and clicked OK. Restart you computer. If new windows still won't work you may have to try re-installing your browswer. Also, STRONGLY recommend backing up your entire hard drive before the procedure. NOTE: This worked for me using IE Version 5.5.

For IE 6 try:

Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll

shouldn't have to reboot...

commented: good post +36

Thanks a lot. The problem seems to be solved. I tried all your run commands with the exception of Msjava.dll as I don't have that on my computer but apart from that evrything else was OK

For IE 6 try:

Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll

shouldn't have to reboot...

good tip, thanks it solved my problem

gobhat

Just wanted to thank antioed and this site, I had the same problem and searched everywhere for a solution, couldn't use Microsoft support because I couldn't open links! Anyway took your advice and my problem is solved. Thanks so much.:)

Same here but no fix. This is very frustrating. Any more ideas? (IE6, XP Pro)

Yep I'm going to have to join the list of happy customers :-)

Not only did it fix my IE new window link problem but it fixed a very annoying problem I was having with windows update as well (I kind of felt that both faults were being caused by the same issue anyway)

Thanks

After runninig these dll'S I opened to 2 new windows then it went back like it was before . I'v ran countless sypware , worm and virus scans with several programs. WORM_SDDROP.C pops up in different places c:\WINDOWS\sCACHE32 files wich are quarantined . PC-cillion says it was found in program where it usually says a file name . I can't seem to find where the worm is hiding do you have any Ideas??

svchost.exe was the file it hide under. Had to run cleanregedit to make the open in new window work so I have no Idea what it changed. Everything is fine again so back to downloading tunes from Kazaa.

For IE 6 try:

Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll

shouldn't have to reboot...

Thanks VERY MUCH antioed! I couldn't open not only IE 6 windows but any windows within IE 6 such as moving a favourite to a folder. I got an error 351. I crashed my machine & connection trying to uninstall IE 6 but eventually got most of it back using Configsafe - all but the windows. I couldn't access my bank!! After reading your suggestion everything works again!!!

I got a trojan and when I destroyed it I destroyed some windows files but ran sfc /scannow which used my XP disk to check and replace files corrupted & destroyed. That got IE working again but YOU fixed the window problem.

You should work for Microsoft if you already don't!!

Cheers

Dave

i tried all the registry commands and they all went successfully except
regsvr32 Shell32.dll

when i entered this command i got the message:

shell32.dll was loaded, but the dllRegisterServer entry point was not found.
dllRegisterServer may not be exported, or a corrupt version of Shell32.dll may be in memory. Consider using PView to detect and remove it.

What does that all mean and what can I do about it?

thanks for this great site and any help you can give.

jheft

Do you mean that you want all links to open up in a new window? I don't think you could set this as default - nor do I see why you'd want to? On the other hand, you can right click on any link and choose "open in new window"

Believe it or not, my boss wants me to find out how to do ths very thing, meaning set this as a default. Any idea on how to do this, is it even possible?

If previos suggestions aren't getting the link window to open...find you original cd and follow the suggestions below. Allow the computer to reboot as it suggests. jp,

HOW TO...Fix links that won't open in new browser

Symptom sounds similar to this...

I am unable to open any links in a new window. A link will open in the same window, i.e., the page will change to the linked page, but when trying to open in a new window, a browser pops up, it is kind of see through, and it never opens to that page....

Answer
This has been a common problem with IE6 on Win98. The usual fix is to restore the oleaut32.dll from the Win98 cab files using the System File Checker:

Using System File Checker to extract files

  1. Go to Start>Run and enter SFC and click OK
  2. Check "Extract one File"
  3. Enter the file name (oleaut.dll)and click on "Start"
  4. In the "Restore from" field enter:: D:\WIN98 [if 'D' is not the letter of your CD-Rom drive, modify appropriately]
  5. Click OK

[if you do not have a Windows system CD, try subsitituting c:\windows\options\cabs in the"restore from field"](however, depending on how the os was installed, these may be blank and you will still need the CD)

Excellent!!

I had this problem a few times and never found a fix. I was using Netscape for awhile because up until now the only time I could get IE to work properly was after a reload.

This fix worked PERFECT!!

Thanks alot antioed

I.E. 6
XP Home

when on a site I click on a link which opens a new IE, the IE doesn't load up the document, how can I set it up where when I click on a link the document can get opened up in a new window? thanks

What version of I.E. 6 are you using? What OS are you using it with? What is the condition of your Tools>Internet Options>Advanced>..."reuse windows for launching shortcuts".

I'm having the same problem as jheft

Phas,

You need to post your question in it's own separate thread. When multiple people "piggyback" their questions on to a thread started by another member it quickly becomes difficult to follow the multiple troubleshoots.

Thanks for understanding :)

- Dave

yep... like to thank forum & antioed... had same problem and could'nt find a solution anywhere... cheers

ANGELS! u r all angels!!!!!!!!nit worked it worked YAY YAY YAY (soz) i had the same prob and it was driving me loopy..yay yay yay

What version of I.E. 6 are you using? What OS are you using it with? What is the condition of your Tools>Internet Options>Advanced>..."reuse windows for launching shortcuts".

I am also getting the same problem. When I installed latest Yahoo Messenger and Companions etc... IE started giving troubles:
1. I could open only one IE seesion.
2. Couldn't click or open the Links.


But, after deleting the Companions and all from Add/Remove programs options, now I could open more than one IE seesion. But, links are not working yet.

I ran all these commands also:
regsvr32 urlmon.dll
regsvr32 Shdocvw.dll
regsvr32 Msjava.dll
regsvr32 Actxprxy.dll
regsvr32 Oleaut32.dll
regsvr32 Mshtml.dll
regsvr32 Browseui.dll
regsvr32 Shell32.dll


I'm working with P4 Windows XP professional.

Can some one post the solution to open the links using IE.

Thanks in advance.

For IE 6 try:

Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll

shouldn't have to reboot...

Jayzus! It worked! I've just got online 3 days ago and this problem had been doing my feckin head in. Fair play yo've saved me about 200 euro in helpline costs and i bet they'd never have thought of that one. Either you're a genius or I'm a langer, or mebbe a bit of both. Thanks a million!

For IE 6 try:

Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll

shouldn't have to reboot...

Hi.. a noob here on this stuff. I tried these but regsvr32 Msjava.dll failed... says the specific module cannot be found. Is dis gonna affect the effectiveness of the rest?