I've read quite a few of the posts on this forum and others about similar problems but i can still not fix this annoying prob!

It only started a few weeks ago I think, but can't think what changes I made, if any! :confused:

I click on a link and it makes the little click that XP does but then it doesn't open it, just does nothing! If u hover over the link it says "Javascipt:.." etc..

Getting so annoying, mainly affects my emails, Hotmail and my university one, cos i can't read the hotmail ones or do much else, and my university one i can only read not reply or compose!

Occasionally though I can read my Hotmail emails, I CAN open them, but I don't know why this is only sometimes not all the time!!

Ive tried removing all Adware/spyware stuff, changed some options in tools>internet options and downloaded some Java thing from MS that was recommended on this forum but still it doesn't work!! :(

Thanks for all ur replies :lol:

I fixed it, i read of the posts on here and did....


Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll


Now all my Javascript links work fine, haven't turned comp off yet will i have to do this everytime? I don't actually know what I have done but its working so im not complaining!!

Firewalls like Outpost can block JavaScript. So check if you have a firewall running.


Michael

I'm having the same problem with mine. I'm having problem with some html links too though. The javascript links I still can't figure it out. I will try this fix. Hopefully it doesn't screw up my pc.

Member Avatar

MrGneissGuy

Thanks for all ur replies :lol:

I fixed it, i read of the posts on here and did....


Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll


Now all my Javascript links work fine, haven't turned comp off yet will i have to do this everytime? I don't actually know what I have done but its working so im not complaining!!

I have this problem as well as a couple others. Whenever I attempt to print, nothing happens, and print preview shows a blank screen. Whenever I attempt to go to Windows Update, the web page is blank. I did attempt the above fix, and all of them said they were completed successfully except Browseui.dll. I got a message saying the file did not exist or could not be found. I tried a search of my hard drive, but when I click on search, a window opens up completely blank except for the little dog wagging his tail, so I can't search for anything on my computer either. I went to Microsoft's web site to search their dll database for this file, and it said there was no such file. This problem happened when I downloaded Service Pack 2. I've also tried removing service pack 2, reinstalling service pack 2, uninstalling java and reinstalling a new java. I even tried disabling all the the options on the security center thing, including the firewall. Nothing has changed. It also appears that I have trouble with flash items in IE and, maybe completely unrelated, Windows Media Player will not open (I get an internal application error box). They all started at the same time, and I've tried all the fixes I could find on Microsoft's website. Nothing has worked yet. Any help would be greatly appreciated.

Thanks for all ur replies :lol:

I fixed it, i read of the posts on here and did....


Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll


Now all my Javascript links work fine, haven't turned comp off yet will i have to do this everytime? I don't actually know what I have done but its working so im not complaining!!

im having problems with this method. whenever i get to msjava.dll i get an error message

"msjava.dll is not an excutable file and no registration helper is registered for this file type"

it would be great if i could ahve some help with this, thanks.

oh and i run windows xp and IE6 SP2

I have xp pro service pack 2. Everytime time I click on a link for any downoad I see the pop up but close righ away.I can download by right clicking and clicking save target as, but every downloaded program will not open. I also can't even open add or remove progs in control pannel. Please help me fix this im waisting too much time.