0

A while back I tried to install Windows XP Black Edition on my computer. Windows xp pro was already installed and I was not able to install xp black edition because some important files were missing in black edition Since then I changed my mind and continued using Windows xp pro. Now, because I started the install of XP black I have this error message whenever the computer starts. It goes to the message "Please select the operating system to start" and if your not quick enough it will go through the whole XP setup thing again. It is quite annoying and would love to get rid of this thing that obviously contains some sort of setup data that stays on my computer. can anyone help me to REMOVE the setup data so I can just boot right to Windows xp pro like I use to? Thank you very much!

9
Contributors
21
Replies
22
Views
9 Years
Discussion Span
Last Post by gerbil
0

You'll have to edit your boot.ini file. Go to System Properties, select the Advanced tab, Startup and Recovery settings, and click Edit. Remove the entire line of the OS you don't want to use. Make sure you choose the right one!

0

You'll have to edit your boot.ini file. Go to System Properties, select the Advanced tab, Startup and Recovery settings, and click Edit. Remove the entire line of the OS you don't want to use. Make sure you choose the right one!

here is boot.ini text, kindly tell me exact line

[Boot Loader]
Timeout=5
Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"

0

remove the last line then save. Once you reboot you will no longer get that message
C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"

0

WAIT!! You gotta edit the default line also. Go Start, Run, paste in:
control sysdm.cpl,,3
...then press Startup n Recovery Settings, Edit...

[Boot Loader]
Timeout=5
Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

0

hey thanks guys speacially @gerbil, now every thing is fine:) thanks again

0

I didnot understand what changes have
you made in the default line in the boot.ini file?

By removing a line in the Boot.ini, it simply means that you give instructions witch OS to boot up from if you have more than one. By deleting a line you're saying that you dont want to boot from that OS, witch is what they did in this tread

0

Frank, if you look at the boot.ini that I proposed you willl see that the Default entry points to XP on its partition - this is the OS that ntldr will turn to if you do not make any selection within the time allotted by Timeout. Having Default point to an OS for which the path and directory are not specified will cause a hiccup. The original Default pointed to the entry Setup makes in boot.ini so as to restart Setup from your hd during installation - it should have been removed later by Setup but obviously there was a glitch. A glitch!!? Windows?

0

How do you remove the operating system you are no longer using, if it is on c; drive?

Roger

0

If it is XP, merely delete the C:\Windows directory. Edit your boot.ini so it no longer suggests it as an option.

0

How do you remove the operating system you are no longer using, if it is on c; drive?

Roger

if theres more than one OS on the C: than you first need to figure out witch one you're not going to use (want to delete). You can determine that by the way it was installed. Say you've installed a second OS also Win XP and you want to use the second one rather than the one that was first installed, then the boot.ini will by default display the OS as it was installed. meaning the OS first installed will be first and the second one installed will be bellow

0

When I bought my computer it had Chines windows installed on C drive. I had English windows xp installed on D drive. But my system will not let me uninstall the Chinese version on C;. It seems that C is the default drive for additions and windows part of programs no mater if they are instaled for the windows on C or the one on D drive.

Is ther a way to uninstall my Chinese version on C without interfering with the English version on D drive? or is there a way to port the information for The English version on c to d drive?

Or am I stuck with having to reformat reinstall Windows and reinstall all my programs.

Peace and Unity

Roger

0

Hi
Theres a couple of things you can do. One is, if theres valuable data on the C drive, then you can backup the data and format that drive. Youll still be able to BOOT from the D drive. That is if you're willing to reinstall you're programs that was installed on you're C, like Nero, Winamp etc.
Or Two you can follow the instructions on this tread on how to delete the Winxp from the BOOT.ini file. Yours will be slightly different but in a easier way, Being it will display with the drive letters C and D. You delete the line with the C as the drive letter. And copy the line with the D drive letter as the option to BOOT from

Hope thats clear enough. Feel free to ask...

0

I have my entire disk backed up on an external disk of the same size. I will try that. I am only afraid that some of my programes wont work as they have left a part of themselves on c drive.

Maybe I will not need to reinstall all of them but only some.

I have already made my computer boot from the d drive. But isn't the boot system on c ?

0

Theres is (or atleast was) a OS on the disk ie Boot.ini on disk C. But since you deleted you're C's OS it will BOOT from D: Thats if D's OS was installed correct. Yes some programs installed on C whilest you were running the C: OS back then will result in you going to have to install it again. However that should be a train smash... Or so I hope :)

0

rbor, enable viewing of hidden op sys files, then check in the root of C: and D: for boot.ini, ntldr, ntdetect.com. Where are they?

0

boot.ini C;windows\pss a backup file
boot.ini not on d

ntdetect.com Not found on c or d

This one not found either on c or d
is there a boot sector on disk that is neither c; or d: ?

0

You should have:
C:\boot.ini
C:\ntldr
C:\ntdetect.com [usually]
If so then C: is your System drive - it contains those boot files, and that is why Windows on D: will not let you remove those files on C:.. it would make your sys unbootable. Right.
COPY those files into D: root.
See if you can set D: as Active using Disk Management [make C: not Active first].If you CANNOT make D: Active then leave C: as Active. We will do it then another way.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.