0

I have a main C: hard drive, plus a secondary drive. The 2nd hard drive is G: and is connected to the proper place on the cable that plugs into the mobo. I can open files on the G drive if there is a shortcut to a file or folder on it on my desktop, and once I open a file from it I can simply click "save" and it saves that file to this G drive correctly. But in any program when I click "open" this drive does not show up on the list of drives. I can't save any files to it for the same reason, unless it is a file opened from this same drive. Device Manager says everything is wonderful with this drive--working properly. It doesn't show up in My Computer or Windows Explorer. I have the jumper set to slave, and I've also tried cable select. When I swap this G drive with another hard drive it is recognized.

This G drive was the secondary drive in my computer for a long time and worked well. Then I cloned my C drive to a bigger drive, which is working OK. Now this G drive works except for the problem I mentioned above. I've tried renaming it in case there was a conflict with some drive of the same name, but that doesn't seem to help.

Both drives are Western Digital C: is WDC WD 3000JB-00KFAO (jumper set to master)
G is WDC WD 800JB-00ETAO

This is driving me crazy. Please help.

Dale

3
Contributors
3
Replies
4
Views
9 Years
Discussion Span
Last Post by gerbil
0

Sounds like a registry issue, have you tried uninstalling and reinstalling it in windows? Also, in modern systems (unless it's a dell) master/slave doesn't really matter. If it works as master I'd consider switching them around.

0

Lessee, if you address the drive from the run command by entering G: does it open in Explorer?
[Start, Run, type G:, press Enter].
Or it opens if you type G: into the explorer address bar?
Then run this:
==Please copy the text in the box to a notepad [format/wordwrap unchecked] and save as fixkey.reg, as type "all files", to your desktop; dclick it to run... agree; if it opens in notepad instead rclick the icon [file], choose Open with, Registry editor....

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDrives"=dword:00000000
0

Actually, the value in this key will override the value in the key in my earlier post:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDrives"=dword:00000000

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.