I have 2 Firewall that I installed (ZoneAlarm & COMODO) and they are still showing active in TUT (The Ultimate Troubleshooter). I cannot turn on or off Windows Firewall. If I try to it doesnot prompt me that I am at risk. I always get a prompt in my other PC.
Any suggestions?

To turn off Windows firewall:
1) click Start>Run>Type services.msc
2) Find the Windows Firewall/Internet Connection sharing (ICS) service.
3)Click on the service>Stop the service>Right click the service then click on properties.
4) Use drop down tab to disable the service.>Then click OK and close the services window.

To stop the annoying prompts:
1)Click the annoying prompt>Click the Recomendations button. > Place a check in the box that says I have my own firewall device (or something to that nature).

PS:
It is not advisable to have more that 1 firewall active on any given workstation. If you do not trust just one find one you do trust.

Two firewalls is one too many. ZoneAlarm ensures that Windows Firewall is off, Comodo does not care - it probably knows stuff. Anyway, more than one is simply an unnecessary drain on your system.
Comodo should be plenty of firewall for any user, plus it has a system defence included. It is by far the most comprehensive, customisable, complex, best firewall of the three.