I recently built a new computer. I installed XP fresh, and installed some various programs that I use frequently. Everything was going fine until Windows Update downloaded SP2. I installed it, and restarted. Ever since then when I start up it simply hangs on the windows loading screen. I see the animation of the progress bar scrolling along under the Windows logo just fine. I even let it sit there for quite a while, thinking maybe it was just going slow, but after an hour or two nothing happened.

I have searched and google'd around, and found people with a similar problem (though none mentioned SP2), but none of the solutions have helped me. Has anyone heard of such a thing, or have any tips on how I might diagnose this?

Hi,
You could try a few things first.
Start the PC in safe mode, Tap F8 as the PC boots.
1. Do a system restore
2. Uninstall SP2
3. Install SP3

Sure that sounds like a good idea, but how do I get SP3 without SP2? Also, will system restore affect my second hard drive or only the drive with windows on it?

no no no

you need SP2 to install SP3

installing SP3 over SP1 or XP RTM is NOT SUPPORTED. SP3 does not include SP1 as SP1 is no longer supported directly.

personally i just reccomend reinstalling. Try using a program called nlite to integrate the service packs for an easier install (integrate sp2, let it build, then exit, reopen and do the same for sp3, then creat the iso)

Ahh... well see the thing is, I have been having trouble with burning CD's and I was kind of hoping SP2 or SP3 would fix the problem. I can read CD's just fine but it seems to have trouble with blank CD's.

When I go in to explorer and click on my CD drive with a blank CD in the drive, it pops up an error message that says "E:\ is not accessible. Incorrect Function."

I should also note that I even swapped out my new CD\DVD writer for my old CD (But not DVD) writer and I got the same error. This is why I suspect the problem is with windows and not with the hardware itself.

Something else I just noticed right now, In windows explorer there is an option for "3.5 Floppy (A: )" but I never put a floppy drive in this computer. Does it always say that regardless?

no youve probably got the floppy controller enabled in the BIOS somewhere

Well looks like I just made things worse. I downloaded SP3, then installed SP2. I started in safe mode and installed SP3 and the problem was still not fixed. So I uninstalled SP3 and it reverted back to SP2, and then I tried to uninstalled SP2, but it turns out I apparently cannot do this because it is no longer in add remove programs... I may just try to reinstall windows completely, as I didn't have TOO much on that new HD anyway.

Err, well I attempted to reinstall, but I can't seem to change any settings in the BIOS, so I can't change the boot device priority. augh... I can view them but I can't seem to edit them... ARGH!

Just an update, I cleared the CMOS and I can now access the BIOS again. Hurray! I'm currently backing up my files that I want to keep to another drive, and I will try reinstalling windows and let you know if that works.