My main desktop computer is set to dual-boot Linux and Windows XP Professional. I have the Linux OS set up to sync time with an internet time service. When I boot the WinXP OS, the time consistently shows four hours late -- as though it's interpreting the system clock to be on UTC (I'm actually in the US EDT zone).

Does Windows have a function, someplace, that can be told whether the system clock is set to UTC or to local time?

Or is there some other possible explanation for this consistent error?

I'm not overly sure, try the regional settings in the control panel, might turn something up.

No dice, but it was worth a look.

Okay, just checked on my windows server 2003 box. It seems it is under Date & Time . You should be able to change the timezone and other time related settings there.

I probably wasn't clear enough. I have no trouble changing the timezone or, for that matter, the date and time. The problem is that Windows appears to misinterpret it.

I have my Linux OS set up to read an internet time server, so that it keeps the machine clock as near perfectly-set as even an obsessive like me can expect. But when I reboot to the WinXP OS, Windows tells me that it's four hours later than it actually is. If I reboot directly back to Linux, the time is again shown correctly.

From this I deduce (perhaps incorrectly) that the system clock is not changed, but that Windows, for some reason, assumes that the system clock is reporting UTC and -- since I've told Windows that I'm in the US Eastern timezone -- Windows adds four hours to the system-clock time to make up for the timezone difference between UTC and EDT.

It's not that I have any trouble telling Windows what timezone I'm in. Rather, I want to tell Windows that the system clock is set for my timezone, not for UTC.