0

All I have a Windows 2003 Enterprise Server which is also my Terminal Server that will not allow me to install any apps.

I had a issue with one of my apps and had to remove and now after rebooting it will not let me install this application back .

I keep getting this error in the system log

Event Type: Information
Event Source: Application Popup
Event Category: None
Event ID: 26
Date: 7/24/2009
Time: 6:08:41 AM
User: N/A
Computer: IOMTERM
Description:
Application popup: ntvdm.exe - System Error : NTVDM encountered a hard error.

Has anyone had this issue before if so can you help with this issue.


TIA

Rongk

3
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by rongk
0

I was having the same error but then I found out some very useful information that should resolve your issue

how to configure to prevent access to 16-bit applications in Windows Server
2003

Requirements: At least Microsoft Windows Server 2003

Location: Computer Configuration\Windows Components\Application
Compatibility\

Description:
Specifies whether to prevent the MS-DOS subsystem (ntvdm.exe) from running
on this computer. This setting affects the launching of 16-bit applications
in the operating system. By default, the MS-DOS subsystem runs for all users
on this computer.

You can use this setting to turn off the MS-DOS subsystem, which will reduce
resource usage and prevent users from running 16-bit applications. To run
any 16-bit application or any application with 16-bit components, ntvdm.exe
must be allowed to run. The MS-DOS subsystem starts when the first 16-bit
application is launched. While the MS-DOS subsystem is running, any
subsequent 16-bit applications launch faster, but overall resource usage on
the system is increased.

If the status is set to Enabled, ntvdm.exe is prevented from running, which
then prevents any 16-bit applications from running. In addition, any 32-bit
applications with 16-bit installers or other 16-bit components cannot run.

If the status is set to Disabled, the default setting applies and the MS-DOS
subsystem runs for all users on this computer.
If the status is set to Not Configured, the default applies and ntvdm.exe
runs for all users. However, if an administrator sets the registry DWORD
value HKLM\System\CurrentControlSet\Control\WOW\DisallowedPolicyDefault to
1, the default changes to prevent all 16-bit applications from running.

Note
This setting appears in both Computer Configuration and User Configuration.
If both settings are configured, the Computer Configuration setting
overrides.
ADM File: system.adm

Hope this helps!

0

Try this:
Log in as an admin
Create C:\Temp folder
Redefine your TEMP environment variables to C:\Temp. Log off and back on.
open a command prompt and type SET T - verify that TEMP=C:\TEMP
Try your install.

Have seen some apps become confused when the TEMP folder is a path that contains spaces, and sometimes isn't translated correctly to 8.3 names. Using C:\Temp eliminates this problem.

Also, (Although I don't remember if its required for 2k3 TS systems) have you tried running CHANGE USER /INSTALL before running the installation? This changes where reg keys get written so they are available to all users in TS sessions.

Glenn

0

I have tried both solutions from the thread and still get the same results.

I have run RegCure and that also didn't help....

Rongk

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.