0

Hello,
I came across a strange problem which never existed in the last 4 years on my computer.

"System: Dell 600m, Windows XP, 512MB RAM, Intel Pro Wireless, Intel Celeron processor, AntiVir AV software (free edition)"

My computer all of a sudden started showing blue screen a couple times but worked well after switching it off and restarting again.But now I could not access internet. Even though my WLAN shows the signal strength is good and its connected, when I open the internet explorer (IE) it says the page cannot be displayed. I tried running some "EXE"s to repair WinSock from this website "http://www.cexx.org/lspfix.htm". But no improvement.

Then I tried the following but did not work.

1. I tried some good spy, trojan and virus removing softwares. But internet explorer is still unable to connect to the web pages.
2. I tried to restore the system to a point where the system was working perfectly alright. Still no good.
3. Tried dial-up connection. It reaches the last successful step, "Registering your computer on the network" and then exits by saying Re-dialing with the following error message:
"Checking network protocol connections...
TCP/IP CP reported error 2: The system cannot find the file specified.
IPX/SPX or compatible CP reported error 733: A connection to the remote computer could not be completed. You might need to adjust the protocols on this computer. For further info click More Info or search Help and Support center"
4. Then I searched in the Help and Support center under Start. As mentioned in the support, I started a window prompt and executed "ipconfig". I get the following error message in the cmd window.
" Windows IP Configuration
Ethernet adapter Local Area Connection
Media State .... Media disconnected

Ethernet adapterWireless Network Connection

Media State .... Media disconnected"

The Support say that the Media State should never be disconnected ! And on my computer it is now !!!

My assumption is that the TCP/IP settings may have gone corrupt (don't know the reason but tried to uninstall some softwares to save space). Desperately looking for a valuable guidance to get back my computer to browsing.

Thanks a lot in advance

5
Contributors
10
Replies
14
Views
9 Years
Discussion Span
Last Post by Shroomie
0

usual way of getting TCP/IP into a state of grace is to go to your network card in Network Connections, Properties/General --> Internet Protocl (TCP/IP) and click Install to re-install.

Let us know how you get on.

0

I would guess that you have a hardware glitch.
Why not try using a borrowed network card from a friend and see if it has any effect on your connectivity.
Faulty hardware could well be the reason for the blue screen.

0

I'm not sure efmesch spotted that you were reporting a wireless issue. Still there's merit in going to your router via direct ethernet cable.

If that doesn't move you forward, in addition to the simple measure in my earlier post, you could try the following in sequence if the earlier suggestion didn't work:

Run --> CMD
ipconfig /release
ipconfig /renew

netsh winsock reset

----------------------------------------------------
All the above said, the blues screen, I take it, has stopped happening. That's usually caused by some memory crash. This, in turn, can be usually be due to misbehaving RAM (less likely) to corrupt device driver (more likely especially if you've done an update recently).

So have you any more to tell us?

0

This is an indepth problem that I have found multiple solutions for. I am now going to list all the solutions, but the very first thing that you should try doing is power cycling, that means unplugging the power to your modem and router, then plugging in your modem first for about 15-20 seconds, then plugging in the power to your router. Then try to see if you get connected to your network if that doesn't work you can try some of these solutions that other people have tried. Also for gods sake people. Please contact your router manufacturer and/or read the router manual. It may have steps listed that you may need to try and it may just involve getting into the setup of the router.

1) there is a setting in your wireless properties right click your wireless connection box go to properties and there should be an advanced button on bottom click it and place a check in connect to non prefered networks

2) I had this problem and found that there was a switch on my laptop that physically enabled/disabled the wireless connection. On some laptops its a actual switch, and on others it's a function key (mine was FN-F2 for a gateway m460)

3) So that was really quick, I talked to a friend who knows about networking and all I had to do was update the firmware on my router. Just find the firmware that applies to your router at linksys.com and you should be good to go. For this solution you'll need a working direct connection to the internet so you can download and install the firmware for your router, this may resolve some issues if it is a firmware issue.

4) I found a website that offers a freeware software download called WinSockFix.exe, which you can also type in google for a search. The URL ishttp://www.tacktech.com/display.cfm?ttid=257. This solution also requires another computer with working internet access, and then requires you to burn/copy/take with a working usb card or something that will store media information, and take it to the computer in question then use this software if it doesn't work continue reading.

Here's a six step fix that may work for you.

1. Go to the control panel & select "Administrative Tools".

2. In Administrative Tools, go to "Services".

3. On the Services screen, scroll down until you find "Wireless Zero Configuration".

4. Start this service.

5. Now go to "Network Connections" and right click your wireless adapter icon.

6. I can't remember exactly which tab it is, but find the one where you have the option
to check or uncheck "Use Windows to configure my wireless connections" or something to that effect. Make sure it is checked.

Here's another solution that may work if you have the right type of software.

What did work was going to "Control Panel", "Add or remove programs", "Intel Pro Wireless adaptor", then "Repair". I suspect this will only work if you are using intel pro wireless adaptor.

Here is a specific fix for a dlink card in windows ME.
http://support.dlink.com/faq/view.asp?prod_id=478&question=DWL-650%20/%20DWL-120%20/%20DWL-1000AP
Here is the solution for Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;239924

You can also try reinstalling the drivers for the card.

This seemed to work for one person.

Control Panel / Administrative Tools / Component Services / Services (Local) / Wireless Zero Configuration.

Go to the recovery tab, and restart the service.

You may also need to upgrade the bios for your computer, one user reports upgrading the bios and getting the wireless card to work. I suspect this may be an internal wireless card issue.

Also you may try moving the wireless card to a new pci slot. It may start working after that.

What eventually fixed it was changing the RF channel at the base station. Mine was originally set up to run at 108Mbs 'high speed' mode, which has to use channel 6 (the middle of the band). I think that this is probably the default for most new out of the box setups as well. I throttled it back to 54Mbs G only mode (which is still more than adequate for my broadband) and switched it to using channel 11 and it burst back into life.

Here's another step that was condensed a bit and explained a little more fully.

1. Right Click on My Computer
2. Go to DEVICE MANAGER
3. Find you wireless card and make a right click and choose properties
4. Click over the ADVACED TAB
5. Find where says something like "WZC" or WZC Managed Ethernet and choose enable.

Note: if the WZC Service is not working you have to go to Control Panel > Administrative Tools > Services and at the bottom you will find a service Called WZC (Wireless Zero Connection) and you have to start that service.

Something someone did may or may not help you. They defragmented their harddrive and then were able to connect to the wireless. So you may want to try this if nothing else has helped.

One person reported disabling the anti virus on their computer, then restarting and connecting to the internet fine, and then re-enabling the anti virus.

Along with reading the router manual you may need to enter the mac address of your computer into the allow mac addresses of your router in order to get connected.

Also another person reported that if you have a 2.4 ghz phone running while you're attempting to connect to your wireless it may interfere.

and a final solution posted.

Things to do:
1) Verify what kind of wireless card/adapter you have: a, b, g, b/g/a, N, etc.
2) Check the broadcast mode on your router. If you have a "wireless-b" card, you need to be broadcasting in either "b-only", "mixed b/g", or "mixed" mode. Note: Sometimes the "mixed" modes don't work; and to support a "b" card, for example, you might have to broadcast in "b-only". Try each of the applicable possibilities until you get the highest common denominator that works on all of your wireless devices.
3) If there are several wireless signals within range, make sure interference is not causing problems. If you see several signals in the available networks list, I would suggest changing the channel to something other than 6 (the default) on both the router and wireless adapter and making sure you have a unique ssid (in case your neighbor has the exact same router).
4) If your laptop/PC still doesn't automatically connect, refresh the list of networks and try the usual steps. It should now work.

Note: Be meticulous on this. Don't @ssume anything.

Moving from my SMC-b router to a Belkin pre-N "broke" my wireless card and it said "media disconnected". Moving back to my SMC router did NOT automatically solve the problem. But many months later, with a new Linksys N router, I decided to try again and changing my broadcast mode corrected it in seconds. I have had similar experiences correcting connections on other systems by simply stepping the mode down to match the problem device.

Hopefully that fixes your problem, if not I'm out of answers. Also you may have a faulty wireless card in which case your screwed no matter what :). Have fun.

0

Well, as nothing worked, I reinstalled my windows (which was my last option) and now I could browse. Not sure if repair could have helped. Well I saw the suggestions from DarkRubicant today and it was too late to try out those. But many thanks you guys for your valuable tips and time.
ciao

0

Sometimes, "brute force" (=reinstallation) is the best solution for the long run.
Enjoy your working computer

0

I have this same problem. Please help! I have tried all of the suggestion listed above and nothing. My networks shows that I am connected but when I try to browse I get the internet explorer cannot display the webpage notice and I have tried 4 different public access sites, I usually connect to the web via my cell phone and that is not working either which leads me to think its not a hardware problem. when I run ipconfig/all it shows all the correct addys, if I have the Local area connection enabled it says media disconnected and I can't get online. If I disable the Local area connection it doesn't say media disconnected anymore but still no web. I have a dell inspiron 6000 with xp. this happened out of nowhere when an automatic update took place. the automatic restart happend as usual and when it came back up no internet. i'm usually pretty good at taking care of these problems by searching forums like this and flollowing instructions but this one is beyond me. Please please help!

0

That was one of the first things i tried. No luck, same thing. ANY advice would be appreciated.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.