0

Hi all,

I want to discuss my recently encountered problem. I'm a newbie in this forum and IT-related issue so please explain the solution as simple as possible if u can.

My laptop and connection condition :
I have an ACER-aspire 5572NWxMi laptop
I am living in a dormitory and internet is provided by dormitory via LAN cable in every room.
I just reinstalled windows XP SP 2 about 1 month ago.
However, one week ago suddenly I couldn't browse internet although my LAN connection indicator showed connected status (other internet related program, msn, antivirus also couldn't work)

Symptoms are as follows :
Connection status is connected, I can get IP address, gateway, dns and such.
I use dhcp to obtain IP (automatic)
Firewall is turned off.
I can ping localhost, it replies all 4 packets.
I can ping my ip address and gateway as well.
But I cannot ping anywhere else.
ping yahoo.com resulted in "ping request could not find host yahoo.com"
ping "public ip address" resulted in "request time out"

I've tried these actions but the problem is still there:
changing the lan cable
use my friend's laptop with my lan cable and it can connect without problem.
system restoring my computer
fixing winsock
turning off all firewall
uninstalling antivirus
reinstalling windows and all drivers

I attached the results of ipconfig /all here.

Thank you in advance for your help and attention.

7
Contributors
10
Replies
11
Views
8 Years
Discussion Span
Last Post by goldeagle2005
0

I've tried ipconfig /release and /renew, and that will only reset my LAN connection, obtain ip address again but didn't solve the problem.

As for ipconfig /release all and /renew all, they didn't work and give this reply "the operation failed as no adapter is in the sate permissible for this operation". I have no idea of what does that message mean.

Thanks for replying anyway, any other suggestions?

0

I've tried ipconfig /release and /renew, and that will only reset my LAN connection, obtain ip address again but didn't solve the problem.

As for ipconfig /release all and /renew all, they didn't work and give this reply "the operation failed as no adapter is in the sate permissible for this operation". I have no idea of what does that message mean.

Thanks for replying anyway, any other suggestions?

not totally sure either ,maybe best to reask you oginal question in the network section ,good luck .

http://www.daniweb.com/forums/forum13.htmll

0

Do a "tracert" to yahoo.com and a public IP address. Do both fail at the gateway address?

I did as you say, and it passed gateway address but failed afterward.

You have activated "Proxy" in your browser settings ?

I don't know much about proxy,so I never set any proxy in my browser. And I have tried several browsers and all failed, so probably the problem is not in browser.

And now my roomate is having the exact same problem with me. So probably the problem is not the laptop but I still dont have any idea of what exactly caused this.

0

Hi there,

Wow good troubleshooting.
This is a software issue since you can ping.

If you have IE7 try to reset it.
Tools > int opt > advanced > reset > relaunch IE.

Try other browsers as well.
A system restore will be a big help.

If these does not work try to go to safemode with networking by pressing F8 on boot. try to browse from there. If you can reinstall a new browser from there. Possibly the IE is corrupted.

Dont use IE8, please

Edited by crunchie: url snipped-keep it on the site

0

Ireng,

Start, Run, CMD to open a command prompt, then type the following 2 commands;

1:
netsh winsock reset catalog
(This resets WINSOCK entries to installation defaults)

2:
netsh int ip reset reset.log
(This resets TCP/IP stack to installation defaults)

Reboot the machine.

Good luck!

AmCiAN

Edited by AmCiAn: n/a

0

Thank you for all of answers. My computer is finally fixed.
I finally figured out that my IP was blocked by the ISP due to virus, and all that I need to do was just to call the person in charge of my internet connection (just call him internet guy) and he unblocked my IP. And what frustate me is it took me more than a week to figure it out. But at least that problem is finished now.

But unfortunately, now I have a new problem, actually it's my roomate's computer that has problem. I posted earlier that when my IP was blocked, I tried to manually configure IP address and I tried using my roomate's IP address (although I know that it will resulted in IP conflict). And all of a sudden, my roomate's internet stop working, like mine.

And now after my computer's working fine, the problem in his computer remains. I've tried to contact the internet guy, and he said that my roommate's ip is not blocked. But all of the symptoms of my roommate are the same with the symptoms when my IP was blocked.

Now I have no idea how to deal with my roommate's computer and what caused his computer to behave this way. The internet guy can help nothing more and he suspected that the LAN card in my roommate's computer is broken. But he can still ping localhost and his IP address, and I assume that nothing is wrong with his hardware.

I'm clueless now, can anybody here gives a comment or suggestions?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.