5
Contributors
6
Replies
7
Views
13 Years
Discussion Span
Last Post by dace69
0

C: failed to initialize sound, MSS reported: Broken waveOut driver - 'buffer done' flag never set.

It sounds like a mismatch between the version of the DirectX driver required by the game and the one on your system. Go to the Run box in the Start menu and type in dxdiag to find your version, then check the version that your game requires. Make sure that your version is equal to or better than the one required.

It never hurts to go to Control Panel -> Multimedia and check your settings there, as well...

0

I appreciate your assistance but that doesn't seem to help. I am running dirextX 9.0 and the game requires 8.1 or higher. My OS is Windows XP - Home Edition(Service Pack 1) if that helps. Also, my daughter has the same OS but the game (Gothic 2) loads and runs fine on hers.

There is a different video card in the two operation systems. I have an ATI Radeon 9100, which was installed at purchase, and she has a NVIDIA Geforce4 MX 420.

In the readme file from Gothic 2, it does say it has a problem with the FSAA on the Radeon 9700. But for all other Radeon's it says no problems.

Any help will be appreciated.

0

Does this happen with any other games? If so, see if there are updated drivers for your sound and video cards. If not, see if you can find a patch or fix for your game from it's website.

0

I appreciate your assistance but that doesn't seem to help. I am running dirextX 9.0 and the game requires 8.1 or higher. My OS is Windows XP - Home Edition(Service Pack 1) if that helps. Also, my daughter has the same OS but the game (Gothic 2) loads and runs fine on hers.

I doubt that it is the video card. It could be the sound driver -- which sound card are you using? I'm in Linux, not Windows, right now so I can't step you through checking your sound settings in the Control Panel (as I suggested earlier), But I will the next time I'm there.

0

Miles Sound System Initialization, he's using Miles Sound System apparently the system I want to get for my Xbox.

Mandrake 9.2 with CVS checkout of wine from dec 2003.
ECS K7VZA mobo with onboard sound using i810_audio module is what fixes this very problem for users running Linux Operating Systems.

For Windows try an Update here

0

The same thing happened to me. Go to the Run box in the Start menu and type in dxdiag; under sound, under direct x features, set your harware acceleration to standard. When I set mine to full it stuttered the game. I'd previously set it to off so I could play Freelancer. How silly I was to expect a microsoft game to play on a microsoft OS without needing to make changes that wouldn't affect anything not microsoft.
I swear, my next computer is going to be a MAC :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.