0

Hey guys sorry if this is posted in the wrong forum im a 1st time user and im DYING for some help here!

so here's the problem...I have a HP dv2500 special edition laptop which runs on windows vista,and up untill a few months ago everything was working fine, then one day all of a sudden my internet would only allow me to connect to any routers as local access only.

i have severel other laptops in my house which connect fine to my router
my hp laptop will only connect local access only to all routers
when plug in witha ethernet cable internet works fine

i could really do with some help on how to try and fix my laptop ive tried for months to do something and have yet to find the solution HELP WOULD BE MUCHLY APPRECIATED

mnay thanks jacob

5
Contributors
5
Replies
6
Views
7 Years
Discussion Span
Last Post by henduo12
0

trying think through I assume you are saying that since it works with cable the problem lies in the fact that when you try to use wireelss it doesn't work.
If as you say the other machines work wirelessy and the one that is at fault can see the router (have you used IPCONG to confirm this? then the problem looks as though it is in the configuration of the wireless details in the computer. Check the wep / security codes, check the Mac address and also check that the firewall is allowing the computer through to the internet (it may be blocking that but allowing local access) Finally check your hosts file and using google ensure that all the entried in the file are bonafide!

M

0

I think its worth mentioning but the HP dv2500 series are notorious for having defective wireless cards.

0

Hello,

I've been having similar problems, and this worked for this configuration:

* Windows Vista 64

* Atheros AR5007 802.11b/g WiFi Adapter on an HP Pavilion dv5z 1000us laptop

* Netgear WGR614v10 router

I could connect with WEP encryption, but as soon as I would turn on any version of WPA, the laptop would get a new IP with DHCP, but the connection would be marked as "local only".

I solved my case by updating the laptop's wireless card's driver from HP's website. Even though Vista was telling me that the driver was up-to-date and even though I couldn't find any new driver on Atheros' website, I went ahead anyway and used the driver provided by HP.

Hope it helps,

Tony Bruguier

0

I have also found on occasions that setting a permanent IP address rather than letting windows apply a DCHP one can solve this type of problem!
M

0

for me it was the opposite: whenever i set an IP address it never worked.. HP is a mess haha

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.