0

Hello everyone.

I hope you will help me with this. I am from Russia so i am really sorry if my English is not good. But I will give it a try...

The problem started when my PC freezed and I had to shutdown it by pushing shut down button longly. After that I had an issue which is the same with this one ( http://www.daniweb.com/forums/thread63865.html ) . I read that thread and got rid of that annoying screen. But the problem was not solved fully. Now I can't change the wallpaper at my desktop.

When I choose a desired image to set as wallpaper (even through display options) the screen just rapidly blinks but nothing happens. But after I relogin or reboot it changes.

1) I had the same problem with my wife's notebook. I just uninstalled IE8, rebooted machine, installed IE8, rebooted and now everything just works fine. I did the same on my PC it didn't help. After that I uninstalled Mozilla Firefox, rebooted, uninstalled IE8, rebooted, uninstalled Maxthon2, rebooted, installed IE8, rebooted, installed Maxthon2, rebooted. But all this didn't help either...

2) I tried to delete desktop.htt then change a wallpaper. After the wallpaper changed new desktop.htt file created and then the problem here again...

3) When I create a new account of OS user I found that everything works fine with it. But when I come back to my account again I face the same problem again.

4) I tried to disable Active Desktop with a special vbs-script ( http://www.kellys-korner-xp.com/regs_edits/activedesktop.vbs ), and everything just works fine. After enabling it again the problem is back.

It is obviously somehow connected to active desktop. But I can't solve because I am just a simple user. Please help me with it.

I use WinXP SP2, IE8, Maxthon2. Already checked for viruses - none was found (NOD32 2.5).

Sincerelly yours Probbayo.

Edited by probbayo: n/a

3
Contributors
12
Replies
13
Views
7 Years
Discussion Span
Last Post by gerbil
0

I forgot to tell that when you try to change the wallpaper and desktop just blinks and stays the same after you reboot or relog the wallpaper changes.

0

Did you try this regedit:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\Components
Change the value of DeskHtmlVersion to zero instead of decimal 272.
Next, change your wallpaper, and then change it back, or to something you desire.

Edited by gerbil: n/a

0

Probbayo, could you post an image [as you did before] but of this key, please?
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\Components

Note... not the Safemode\Components path...

0

Oh... My bad... Don`t know how I did this stupid mistake... Thank you!

I tried to change the specified path to decimal zero. But after reboot it is 272 again...

http://img200.imageshack.us/img200/3663/54545z.jpg

added:

Tried this way.
1) deleted desktop.htt.
2) changed key to decimal 0.
3) refreshed desktop
4) new desktop.htt was created.
5) the key value changed from 0 to 272

and your way

1) changed key to decimal 0.
2) tried to change the wallpaper from display options (failed)
3) the key value changed from 0 to 272

Edited by probbayo: n/a

0

added 2 :

the key value of GeneralFlags changes back to 1 itself too if you edit it.

0

Probbayo, I'm not getting anywhere with this remaining problem of yours... "I choose a desired image to set as wallpaper (even through display options) the screen just rapidly blinks but nothing happens. But after I relogin or reboot it changes."
May i suggest that a simple solution would be to create a new user profile for yourself, and then copy over your user folder CONTENTS [Documents and Settings\Probbayo\...].
If it works well, simply remove the old profile.
DO NOT try to copy over your user folder itself to the new user profile, only copy the contained folders and files.
Not what I wanted as a solution, but it should work.

Edited by gerbil: n/a

0

hi

try this...
Right click on your desktop, then click on properties and the go to Desktop, then click on Customize Desktop, then click on web, there uncheck "Lock Desktop Items" and remove any in the web pages "web pages", and leave My Current Home Page. ok try this and tell me if you again face any problem.

Thanks..

0

Gerbil, thank you. Maybe I ll do it like you say, but I just want to understand what is it with my OS. Why it always resets the registry keys to 272 and 1 as I wrote before.

LoganJames, thank you for your efforts but Lock Desktop Items and My Current Home Page are already unchecked and there are no any web pages more. Actually I never used them on my PC...

0

I do understand that approach, Probbayo, but a fix is a fix and creating a new user and passing over the contents would take you less than a minute.
I cannot find anything on GeneralFlags of any use, just that setting the second bit means desktop locked. I do not know the usage of the first and third bits.
Cheers.

0

Thank you, Gerbil. I'll try that way one day maybe. But I am afraid that it is not possible to move all my programs' settings and registry values to a newly created account in a minute... And of course my skills are lack of that ability to do it by myself... I really dont know what folder I should copy and what not. Anyway, thank you again for your try.

If we understand why the registry values change themselves, maybe we will solve the problem. Anyone has an opinion?

0

Probbayo, from monitoring activity I can tell you:
-if GeneralFlags value is 0 then explorer.exe will set it to 1 at shutdown.
-if I stop the explorer process before shutdown leaving GeneralFlags = 0 then explorer will read it at boot time and reset it to 1.
-if I stop the explorer process leaving GeneralFlags = 0 and then restart explorer, it will read the 0 and reset it to 1.
-if GeneralFlags = 1, 2, 3, 4, 5 then when it is read at boot time [ or explorer start...] it is then set at that same value.
GeneralFlags is a 4-bit value, and 0 is probably invalid.
DeskHtmlVersion is likewise reset to dec 272.
These are obviously actions inbuilt to explorer.exe. I don't think I can do more...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.