0

Hello, recently i found one of my old USB devices but when i plugged it in and tried to delete a file it told me it was write protected. Now i have decided to format it but it doesnt let me because it is write protected. It doesnt have a slide button to turn off write protection, and ive tried multiple low level formatters in vain. I also tried to delete partition, and to change the regustry value to 0, but that doesn't seem to work either!

The USB is 1GB and it isnt a brand name USB as far as i can tell. Any suggestions on how to format it would be greatly apreciated. Thanks.

4
Contributors
16
Replies
19
Views
7 Years
Discussion Span
Last Post by khakilang
0

have a 2GB drive that has suffered a similar fate. I would be very interested in an answer, but hopefully have no hope to offer you at this point, as it would seem you and I are in the same boat. The only saving grace, it seems, is that the data is fully accessible, so I can back it up elsewhere, and then kick the unit to the curb.

It seemed to become read-only after an unfortunate interruption of power (drive removed too early from the port). I realized this could cause corruption, but didn't know it could cripple the drive in this manner.

0

I dont mind if i lose my data as long as i can make it usable again, but i cant fomrat by normal means, or by the mentioned methods.

0

Maybe you can try this. Right click on the file in the USB device and see what the message say. The file could be convert to read only. You will see it mark. Just click on the mark and try again. You may have to do it on every files in the devise. You can't do anything on the device if some of the files are mark as read only. This is a security as some people tend to delete the files or format the device accidentally. Post it and let us know.

0

Well i checked the properties of the files on the USB and this is an example of what i found.

None of them are read only, but for some reason they are archived.

Attachments EXAMPLE.jpg 142.77 KB
0

Can you click the archive and unmark it? Try to unmark the file and see whether you can use it. Sometime it could be due to repeating saving the same file. Let us know what you found.

0

all the files are archived, and when i try to unarchive them i get the following message
'an error occured applying attributes to the file:
E:\(file name)
the media is write protected.'
It gives me the option to ignore, ignore all, retry and cancel.

0

One last shot. You can go to Control Panel > Administration > Disk Management and right click the USB device and format it. After this I hope someone have better idea because I run out of it.

0

Unfortunately this doesnt work either,

i get the error message under the 'logical disk manager'

'the operation did not complete because the media is write-protected'

so i guess i'll leave this thread open for suggestions.

UPDATE : I just find out that one file is set as read only, but it is a folder called VIDEO with 2 videos in there. The videos themselves arent set as read only, but the actual folder is. When i try to unset the read only the following happens (IMAGES). If i try to apply to the subfolders aswell i get a message saying it is write protected, and i have to choose ignore twice, and when i try to apply it to just the folder, it appears to work, but when i check it again it still says read only.

Edited by SSSD: UPDATE

Attachments READ_ONLY.jpg 248.27 KB
0

yes i have given it a scan and there doesnt seem to be any problem with the device

0

If you can access to Mac or Linux computer. You can use 1 of those to check your pen drive. I use Linux that has a Disk Utility to format any drive under different format even Window NTFS format. That might over ride your current setting in your pen drive.

0

Unfortunately i dont have access to any other OS's because everyone i know uses either XP or Vista, i tried to use my ps3 slim but when i tried to delete the specific folder it told me that the usb drive was locked, so no luck there. Any other suggestions? if not i'll be happy to just give up!

0

Not saying that my issue and SSD's issue are the same, but running under Linux, I repeatedly get the error: "Sorry, could not change the permissions of "B07B-4462": Error setting permissions: Read-only file system"

Could you share the name of that Linux utility? I do not expect anything will come of it, but who knows, maybe?

0

I use Disk Utility in my Ubuntu 10.04 Lucid Lynx. I am sure they have something similar in other Linux OS. Here is a screen shot of the utility. I hope you find it useful.

Attachments Screenshot-5.png 125.48 KB
0

At first I did plan to buy a 16gb pen drive but the cost is not justifiable. 1 pen drive cost RM80.00 (RM3.60 to US$1.00) and a Seagate 250gb 2.5" external hard disk cost only RM135.00. But than again buying a new pen drive does not solve the problem. Still like to know the results.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.