This isn't the first time I've had this problem and the last time I had it, I didn't note down how I fixed it. I just spent the last hour or so looking for solutions to this online and to my surprise, nowhere actually has an answer.

My external hard drive would randomly disconnect for just under a second then reconnect. When searching online, I found someone suggesting that the USB port doesn't have enough power to it to power the hard drive and suggested unplugging all non-essential USB devices. I didn't think it would solve it but I tried it anyway but to no avail. Here's the things I've tried:

-remove the hard drive from the device manager so Windows re-installs the drivers
-unplugging all USB items besides the HDD so no other USB items were plugged in.
-tried different USB ports
-tried the HDD on different computers (it works on others with no problems)
-looked for a powersave setting to make sure Windows isn't turning it off due to inactivity (couldn't find any option for it)

This is quite annoying as I'm trying to watch some of my old home videos I have saved on it and it keeps disconnecting in the middle of one.

Windows XP Pro SP2
Freecom 250GB External Hard Drive (not sure of specific model number. Bought in 2005)

If I've missed out any information, just ask.

Hmm, I would go with the same suggestion your USB port is low on power, try different ports. Also try a different computer.

That wasn't the problem.

I had a look in the device settings while it was connected and noticed it was set to "...for quick removal" so I changed that to "..for best performance."

I'm not on a windows machine right now but next time I get onto it, I'll write down how to change the settings step by step for anyone who has this problem in future.

It seems that my solution didn't work. It's now disconnecting randomly again.

Could I just mention, finito, that I did state in my original post that I had tried the hard drive in different ports and on a different computer.

Are you getting RCR Redundancy Problems when you are able to copy onto the drive?

I don't remember if it was RCR or CRC.

Anyway this could mean the the External Hard drive board is bad. If you can open it up, and try to plug the drive in directly it might work. You can buy another external Casing.

But it could also mean your drive is dieing or dead. I suggest you open it up, and try it on your PC directly before proceeding to clarify if the drive is still alive.

It's CRC and there are no problems when copying files over to other computers. I'm pretty sure it's still alive because it's working on other computers with no problems.

-tried the HDD on different computers (it works on others with no problems)

Aah yes I see, then your ports are fried, you can buy a Pci USB hub.

something like this

They cost like 30~50$ or maybe your power supply is weak (This would be a rather low possibility)

I doubt it's the USB ports because anything else I try in them works fine.

I think that the PSU is the likely thing although the hard drive does work fine with other computers using a weaker power supply but it could be that mine has degraded. When I get the chance, I'll try replacing the PSU. I really do need a new computer though so I might just hold out until then.

Borzoi, The USB hard drive requires a substantially higher amount of power compared to "anything else". I still say it's your ports.

My external hard drive isn't mini-USB and has it's own power supply.

So you are using the 3.5 Standard Drive.

In that case I am not sure, those drive don't have this problem.

Can you do a small test, Try downloading Ubuntu from and run it live from CD. it will load a virtual OS running from your CD, from here plug in your drive this should verify if your problem is hardware or software.

I have a few different live CDs of different operating systems so I'll try them all. I'll let you know how it goes.

All my Linux operating systems detect the drive but are unable to mount it so I can't get a fair test.

Hmm, Your Drive is formatted to NTFS or Fat32?

Not all LiveCDs have NTFS-3g.


The problem with Linux (and Mac) not being able to mount it has been there since the beginning. I remember it saying in the manual for the hard drive that it was only tested on Windows and may not work on other operating systems so that's expected.

I also tried on some non-live versions: Fedora Core 8 and Ubuntu.

? I havn't seen any drive that I wasn't able to mount on Linux even NTFS. Hell if it doesn't mount in Windows it will in Linux.

I strongly believe you have a hardware fault. Either the PSU or the port.

I can see why you've come to that conclusion and I did too at first before I did tests. I think the reason the drive doesn't mount on anything other than Windows is because of the hidden partition it has.

Then un-hide it. But frankly, I don't see how that could affect Windows or Linuxes. It's just a bit set... the OS doesn't often care too much about the actual position of stuff on the disk, that is the job of the local controller - the OS wants to be able to understand the format and read the partition tables, and the partition MFTs, and make/accept requests of the drive, is all.
Anyway... could it be an interrupt priority problem? Does any other ext hdd behave the same way when doing the same task? Have you checked the tables for errors?

That's something I haven't tried, gerbil. I currently don't have another external hard drive to test that with but when I do, I will test that.

Borzoi, some help for the hide/unhide partition action. Disk Mgmnt console won't let you do that, it won't even remove an Active marking of a partition. These tools will do all that, and are straightforward to use:
MBRWhiskey [GUI], or
MBRWiz [command line version]. To use this one just copy MBRWiz.exe to C: root, run cmd and change dir with cd \ then type mbrwiz /? for a list of commands.

The drive won't stay connected long enough for me to run it.

Does the hard drive use only 1 usb port or 2? My external HDD cable has 2 adapters. When I use the usb port on the motherboard, I only need 1. When I use the front panel ports I need to use 2. Is the port on the external HDD clean? I had 1 speck of dust in mine 1 time and it did the same as yours.

The hard drive only uses 1 USB connector but has it's own power supply. I've tried in all the USB ports in my computer. When I get the chance, I'll check for dust.

Do the unhide on another computer.

All my others are linux so I'll need to wait and see if a friend will let me use their's.

I can't believe your drive won't mount on a Linux system. Not calling you a liar but it can't be that.

You can use VirtualBox and try to mount the drive from there.

It shows up on lsusb at least?

Yes, it shows up, it's just that whenever I try to access it I get a "could not mount" error.

I have just found out that my netbook is failing to mount all USB drives not just external hard drives so I'm going to try fixing that then try the external hard drive in it again.

Wait this whole time you were talking about a netbook?

No. The Windows machine is a desktop. The netbook is what I'm using to post these messages, which is running Fedora Core 8.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.