0

I have a PS2 Compaq MX-11800 combination keyboard with trackball mouse.

The keyboard/TB mouse work find on my HP xw6000 PC running XP Pro SP3 and will work OK in combination with a USB mouse (not that I want both).

When the keyboard/TB mouse are connected to my HP Pavilion t645.uk PC running XP Pro SP3, the trackball will not work, although it appears in device manager as a PS2 mouse without showing any issues.

On both PC's the resources and drivers appear to be the same and a separate standard PS2 mouse connected to the HP Pavillion works OK, so does a Microsoft PS2 trackball. I've checked the physical PS2 socket on the HP Pavillion and closed up the socket recepticals just in case, but still no joy.

I always do a full power down before connecting/disconnecting PS2 devices. I've tried the USB mouse through a Microsoft USB to PS2 adapter and 2 different PS2 to 9 pin serial adapters (one MS and one a.n.other) and none of them will work.

I don't have a specific driver CD for the device - it has always worked with the generic drivers that come with XP Pro SP1a, SP2 and SP3.

However, I've just realised the xw6000 PC operating system was built from (Hewlett Packard) XP Pro SP1a then updated with SP2 then SP3, whereas the t645 operating system was built from (Hewlett Packard) XP Pro SP1a and updated with SP3 only. I have read in odd places, now I come to think of it, that to update XP Pro SP1(a?) straight to SP3 can cause problems. But then again I've also read that this is complete 'eye wash' and as SP2 is no longer available from Microsoft I'd kind of lean towards the 'eye wash' camp.

I've done alot of searching on the net but so far without success, therefore, any suggestions or help would be much appreciated.

Cheers.

3
Contributors
4
Replies
5
Views
6 Years
Discussion Span
Last Post by Bear166
0

Thanks for that benmar. It needed a clean but still no joy. If it had of been dust that shouldn't stop the trackball buttons from working, which they don't.

0

Solved the problem.
Either the mobo or trackball are working outside of their spec (volts and or current) or the spec of the two devices does not overlap enough (volts and or current). I've connected a powered PS2 range extender and the track ball now works, yippee.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.