0

Hello all,

We have a server with windows 2003 sp2 on it. My machine is running windows 7. Im trying to figure out why I cant remote in after the other I.T. guy was messing around in the server. The servers firewall has the exception to all remote connections, Remote connections is enabled on both the server and my machine, I can ping the server and can even go into it through the Network link in windows explorer on my machine. Can someone please tell me what is going on?

Btw, we have another server that is strictly dedicated to being a dns server. My dns settings is openDNS(208.67.222.222) and 8.8.8.8. Does dns directly affect remote connections to the server? Thanks for your time mate!

2
Contributors
10
Replies
11
Views
5 Years
Discussion Span
Last Post by JorgeM
Featured Replies
  • 1

    > My dns settings is openDNS(208.67.222.222) and 8.8.8.8. Does dns directly affect remote connections to the server? Thanks for your time mate Hello, So if you are absolutely sure that the server's local firewall has the proper exceptions AND that remote desktop is enabeld, I would continue to focus on … Read More

  • 1

    I guess we posted at the same time. Since you can access the server via IP, the issue does seems to be related to your client DNS settings. Do you have a DNS server running on your LAN? If so you should point only to that server. Make sure on … Read More

  • 1

    So on server-2 you need to create a DNS zone. Open the DNS console right click the server object and click on new zone. Create a primary, go through the wizard. You need to think of a domain name. If its just internal stuff, you can name it something like … Read More

  • 1

    > How do I configure the dns server to forward to openDNS? Do I go change the dns of the server itself? From the DNS console, right click the server object, go to the Forwarders tab. Add the IP of the openDNS server in the list of forwarders. Depending on … Read More

  • 1

    So, let's take a step back for a moment. In summary... You mentioned that you are unable to remote to one of these servers from your Windows 7 client. My recommendation was to test via IP which you did and it was OK. You were not able to from the … Read More

0

Btw, I can remote log in to the server using the ip address of the server but cannot use its fqdn. I do not understand why. Please help relieving my mind on this issue.

1

My dns settings is openDNS(208.67.222.222) and 8.8.8.8. Does dns directly affect remote connections to the server? Thanks for your time mate

Hello,

So if you are absolutely sure that the server's local firewall has the proper exceptions AND that remote desktop is enabeld, I would continue to focus on troubleshooting at the Windows 7 client. If the Win 7 client's DNS settings are openDNS and Google's Public DNS, that would be a problem if you are trying to connect to your server by hostname. The reason is because if you try to connect via hostname, your Win 7 client will send a query to your primary DNS server (openDNS). The openDNS servers do not have any information about your internal server so therefore, they will respond with no valuable information with regard to the server's IP address, and the client will not be able to connect.

To troubleshoot this issue, try to remote desktop to the server by typing in the IP address of the server in the remote desktop client, instead of the hostname. What is the error message you see?

If you are unusure if the Server's firewall settings are correct, just temporarily disable the firewall on the server.

Post back with your results.

1

I guess we posted at the same time. Since you can access the server via IP, the issue does seems to be related to your client DNS settings. Do you have a DNS server running on your LAN? If so you should point only to that server. Make sure on that DNS server you have a zone created for your internal hosts. Create te appropriate A records.

If you do not have an internal DNS, you can modify the local HOSTS file on each computer in your local network, but this requires more manual administration.

If you need further clarification, let me know.

0

Thanks JorgeM!

So to make things easier, I will name our servers server-1 and server-2. server-2 is running DNS and DHCP, and even when I do change the dns ip on my machine to the correct server ip running DNS, I still cannot remote in using the server fqdn. So obviously I need to create the appropriate A records.
However, I have never done this. Can you give me some pointers mate?
Once again, thanks for your help and quick response:)

Edited by SyncMaster170

1

So on server-2 you need to create a DNS zone. Open the DNS console right click the server object and click on new zone. Create a primary, go through the wizard. You need to think of a domain name. If its just internal stuff, you can name it something like domain.local. Once the zone is created, you can add records. Also, open the DHCP console and update the scope so that you are your clients to your DNS. Note that on production networks having at least two DNS servers is best practice to ensure highly available services.

You may want to configure your DNS server to forward to openDNS and google, but DNS resolution will work regardless because the server is configured to use root hints.

Try to get the zone created and the records first, let me know how that goes.

0

Thanks JorgeM!

Sorry I didnt state this earlier, but server-2 already has dns set up, and the other server is in the forward lookup zones along with every workstation. I do need to set up dns on server-1 just for best practice like you stated. How do I configure the dns server to forward to openDNS? Do I go change the dns of the server itself?

I hope im not a bother to you, but my major was CSST(Associates in Computer Science) not a CCNA networking admin. Dont get me wrong I am skilled in other I.T. fields(programming, website design, building machines, troubleshooting, etc.) But I do not know everything about servers. I would say I am a novice when it comes to dns knowledge. I do know some terminology but not all, when it comes to dns that is.
But once again my friend, Thanks for your time.

1

How do I configure the dns server to forward to openDNS? Do I go change the dns of the server itself?

From the DNS console, right click the server object, go to the Forwarders tab. Add the IP of the openDNS server in the list of forwarders. Depending on the OS version, the screens are slightly different. I have some guides on DNS forwarding on my web site, but a google search on how to configure DNS Forwarders, should provide you with tons of articles. With regard to your DNS's TCP/IP configuration, I would suggest that you point it to itself. Just type in the IP address of the server in the TCP/IP DNS client setting. If you have another internal DNS server, you would add that one as secondary. Let all of your internal DNS traffic be sent to the DNS server service on that box.

But I do not know everything about servers.

You are not bothering me and if you were, it would be my fault since i am the one responding to your posts.... In any case, no one knows everything about everything. today I am helping you, hopefully tomorrow you can help me. I know quite a bit about DNS so, no worries, I will continue to assist you as best as I can.

0

Thanks so much mate, I will post back tomorrow, I am leaving my office now. Have a great day!

0

So i still cannot figure out why I cannot remote into the servers with their fqdn, but this is Lan adapter dns ips for the following servers:
server-2(DNS Server)
prefered: 127.0.0.1
Alternate: 8.8.8.8

Server-1
prefered: 208.67.222.222
Alternate: server-2

There is also a virtual machine runnin windows server 2003
For simplicty, we will call it vm1.
Here is its dns ips:
prefered: server-2
alternate: 192.168.1.1

I need a second opinion on whether or not these settings are good before I proceed to tackle the fqdn issue. Thanks again!

Edited by SyncMaster170

1

So, let's take a step back for a moment. In summary...

You mentioned that you are unable to remote to one of these servers from your Windows 7 client. My recommendation was to test via IP which you did and it was OK. You were not able to from the Win 7 client using the FQDN. That tells me that its a DNS client issue on the Win 7 machine. When you looked at the IP config, you mentioned that it was pointing to internet public DNS servers. My suggestion was for you to point your internal clients to your internal DNS servers. Your internal DNS servers would have a zone where this FQDN record would be hosted.

With regard to these three server's DNS settings, that would not have any effect with regard to not being able to remote to them from the Win 7 client.

However, since you asked the question, I will provide some feedback.

I would not recommend that on any of your internal clients, you configre the primary DNS as your internal and the secondary as an external. You should always point to at least two DNS servers that will be able to respond with the same information. For example, what I mean if lets say you have a zone on your internal DNS called "domain.local". So far so good...but now you have your client pointing to your internal and one external. The external DNS has no knowledge of "domain.local" If you client queries the primary, it will respond with an authoritative answer. However, if your client queries the external, it will have no way of resolving this query. In this case, depending on which DNS server your client queries, you will get a different answer. Not a good design.

If you only have one DNS server internally, my suggestion is that server-2 points to itself. Server-1 points to server-2 for DNS and VM1 points to server-2. No secondaries. The next suggestion is for you to load the DNS service on server-1, for example. Then go back and update the TCP/IP configuration so that your internal clients piont to server-1 and server-2.

But again, the client DNS configuration on the three servers listed above have no impact, negative or positve with regard to the Win 7 client remote controlling to it.

So, try this...point the Win 7 to server-2. Make sure server-2 is running DNS and that you have a zone hosted there. Add an (A) record that maps to the server you are tyring to remote into.

From the Win 7 client, open a command prompt, type NSLOOKUP hit enter. Then just type the FQDN and make sure the name resolves to the correct IP.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.