-1

when I try to enter the C: root, it goes to C: \ Users \ PC1>
so I've tried pressing E: so it goes to E:>
when I saw press C: so it goes to C: \ Users \ PC1> again,
it has worked until today, but now it does not work, why would it not now,
I have tried to restart the computer but it still does not work.

I have tried the following commands
c: it does not work
cd to go one directory back, does not work
in E: it works

Votes + Comments
cmd
5
Contributors
7
Replies
8
Views
4 Years
Discussion Span
Last Post by ome2012
0

C: has worked but it does not work now,
when I try E: it works

0

Now have a friend solved the problem, he says there was an error in windows
but thanks for the answers :)

0

No error in your Windows - that is how cmd works. It remembers the last path in any drive. If from c: you enter e: you are not giving it any real directory to go to, so if you have not previously [in this cmd session] been to the e: drive then you will get e:\ ie e: root. If you then cd to e:\folder, then enter c: you will go back to the path you last used in c: [the default start directory is c:\Docs n Setts\You]. Entering e: again will take you back to e:\folder. e: is not a particular path instruction, it simply changes the drive to the last path used there.
It's how it is. And to jump to a deeper path in a new drive you must use /d parameter. So from c: you would enter cd /d d:\"other folder"
And cd \ takes you to the root of the drive you are in. If you are in c:\folderofstuff, entering cd \ is the same as entering cd c:\ It's what you would expect.
With markdown, pay attention to what you are typing.... you don't always get what you expect. To get c:\ to print you must type c:\\ ; typing c:\ will just get you c:. But if there is a space beeween the c: and the \ then you get your c: \ as you type it.
Sheesh.
Really. Sheesh.

Edited by gerbil

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.