0

I setup a brand new Windows 7 Pro PC a few days ago, and connected an HP LaserJet 1022n via a network connection (TCP/IP Port). The printer worked fine.

After a couple of days of successful printing, the user asked me to add a Dymo labelwriter, which I successfully did. However, that printer uses an add-in to print labels from a contact management program, and I had a difficult time making the add-in work. I kept receiving errors that I did not have permission to access certain windows folders. Frustrated, I used the "take ownership" command on the entire C:\ directory. Subsequently, the add-in worked, but now the Laserjet will not print.

Printing a document (or a test page) results in the job appearing in the printer window, sitting for awhile, and then a print error occurs. Nothing ever prints. Stopping the print spooler, I go into the spool folder and see the job files sitting there, which I delete, and then restart the print spooler.

I have removed and reinstalled printer - but its crazy, because I know the printer worked before! I know the driver is fine for this reason as well.

How could taking ownership of everything in C result in this problem? Why can I print to other networked printers from this machine, or the local label printer?

Help!

2
Contributors
6
Replies
8
Views
4 Years
Discussion Span
Last Post by JorgeM
0

By the way, no specific print error was given, unless it showed up in the event viewer which I didn't see.

0

Try assigning a generic (built into the OS) HP LaserJet driver just to test if this is driver related.

0

OK, I will try that (user goes to lunch in about 10 minutes), but this same driver worked before!

0

I understand. Without have obversing exactly what occurred, its hard to tell exactly what the problem is. Just taking modifying the permission of ownership on the directory structure would not cause this type of problem.

If you apply a generic driver and it works, then there is a problem with the driver performing as expected.

If it doesnt work, there is some other Windows related issue with the OS. At that point, I may try a system restore in hopes you can get it back to the point before you had this issue.

I would then try a re-attempt on a test machine where you are more at liberty to make changes to the system without worrying about impacting the users.

0

Hi Jorge,

Sometimes you can't see the forest through the trees. I used a generic driver and it works! Somehow, the factory driver I was using must have become corrupted (I was installing it over a network, not from a CD). I just assumed, hey, it worked 2 days ago, it should work now. Thanks for this suggestion.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.