0

So I have an ESXi host and RAID problem with an Intel Server S1200V3RP motherboard. Basically the problem is that the ESXi 5.5 host isn’t recognizing the RAID array I setup with the integrated utility. See images below for what I mean.

Click Here
Click Here
Click Here

I did some digging and my research has pointed me to the possibility that this raid controller on the intel server isn’t actually a hardware controller but a piece of embedded software using the computer as the controller. My research tells me basically that ESXi is super picky and dosent play well with fake RAID. Granted I could be wrong about that but the behavior from ESXi and every website I’ve found says this might be the case. I’ve tried embedding the storage and RAID drivers into the ESXi iso, I've tried updating the BIOS chipset with the Server Deployment and Management disk, and I've tried mounting a USB with the drivers but nothing seems to resolve this particular problem.

Since ESXi won’t recognize the array as anything other than dedicated disks I tried some inventive work arounds by switching to ACHI mode on BIOS and installing ESXi 5.5 host on a dedicated disk (volume 0). Then I switched back to RAID and used the Rapid Intel Storage Management utility to configure a RAID5 from the three remaining disks. This appeared to work fine and I was able to access the ESXi environment from vsphere. However I couldnt see the RAID volume still on vsphere storage.

I schemed a plan where I would load up the disks as individual data stores on the host and through a virtual machine server use the disk management utility or an alternative program to RAID the 3 hard disks together so they appear as a single volume. However when I booted the system back up it appeared as though the integrity of the RAID5 degraded after adding each drive separately (probably because it had to load up a VMFS onto each drive thereby breaking the array). So this probably won’t work (and even if it could it’s probably needlessly complex).

Click Here

So yeah I really do not have any clear idea of where to proceed to get the integrated RAID controller to be read by ESXi. I was told there may be compatability problems between VMware and my Intel server model but I checked and its on its approved compatability list so that couldnt be it. I guess I could just stick with dedicated disks and load up the HDDS as individual datastores, then use software RAID through a virtual machines - but I am worried about how redudnancy will behave when one disk eventually fails (could I just swap them out like a hardware raid?). I'm always told that software RAID (particularly disk management on windows server) smb read and write speed is terrible when compared to RAID hardware.

Anyone know a solution to this problem or where I could go from here?

Edited by Patrick_5: editing typos adding content

3
Contributors
3
Replies
22
Views
2 Years
Discussion Span
Last Post by Omni
0

Right off the bat, you need to check whether the hardware is on the Hardware compatibility list for ESXi.
http://www.vmware.com/resources/compatibility/search.php

If it's not on the list, I would say don't even bother trying to fix it. Even if you do get ti working, there is no guarantee on stability.

As an alternative, you could always get the Xen server for citrix. Free for a single host.

0

Like I said in the original post it was shown in the compatability list (see below) so no thats not the issue.

Click Here

0

Anyone find a solution for this problem? I'm also dealing with a similar issue and my server is on the compatability list. I was forced to create a software RAID set on my Windows Server and the performance is no where near as good and I lack any kind of redundancy.

Help?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.