0

I have a SBS 2003 server running hosting web and email. I have mulitple accounts which have the ability to use for example http://domain.com/remote to access their desktops, email through a web browser.

I recently installed PHP 5.2.1 which seems to be working just fine. If you access the phpinfo.php test page everything reads correctly.

I installed Squirrelmail a week ago to have a easy & faster interface for users to access email on the run. All was working great until last weekend. When you go to login now I get "You must be logged in to access this page."

I have gone and read all the support pages I could find for squirrelmail and followed all the directions I can locate of resolving and configuring squirrelmail to run. So basically I started from scratch removing Squirrelmail & reinstalled it. I did the manual configuration modifing the config.php.

Now the first time I installed it I only had to modify the config.php file, most directions and forums also directed to modify the redirect.php file

Replace the header("Location: $redirect_url"); in src/redirect.php with the line:

echo "<html><head><META HTTP-EQUIV=\"Refresh\" CONTENT=\"0; URL=$redirect_url\"></head><body><a href=$redirect_url>Enter</a></body></html>";

Now when I do that all I get is a blank page when I log in. But when I did not replace that line it would work, until now.

The only updates I know were put on my server since it last worked was security update for windows media player. I've done some reading on that and did find a few modifications it made.

So I went into the regiserty and set HKEY_CURRENT_USER/ SOFTWARE/ MICROSOFT/ MEDIAPLAYER/ PREFERENCES/ WebScriptCommandsEnabled=0 to 1 to enable it.

Also if you run the configtest.php page it states that it appears that Squirrelmail is installed correctly.

So any suggestions on what may have occured to suddenly cause it to not work or any thought on the windows media player security update and what I may do to change either the php code on the redirect.php page or system wise what I maybe able to modify to get this simple app working again.

Thanks
Wade

2
Contributors
3
Replies
4
Views
10 Years
Discussion Span
Last Post by DimaYasny
0

I apologize I should have added in my post that I did try a new password and even created a new user. This effects all users not just my account. It effects Admin through basic users.

But the original password I can still login the system from the terminal, remotely and through Outlook. It seems that a security change took place automatically that is not allowing a php script to run correctly.

0

I'm no pro when it comes to php on windows, but I do know SBS enough to hate it :) it is too filled up with unneeded features, and it generally assumes it knows better then the admin as to what it needs to do. having said that, I want to mention the fact that win2003 sp2 just came out, and your sbs might have downloaded and installed it. I've tried it yesterday, and that sp2 thing, seems to not show itself in the system.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.