0

For the last few days whenever i try to download a file neither the built in download manager nor the add on download manager work.

The download goes straight to the desktop(or wherever else i direct it) meaning i cant see the status or any of the other information that is usually in the download manager.

I tried uninstalling the add on download manager along with all other add on's and extensions but it didnt fix the problem.

I also tried completely uninstalling firefox but this didnt work either, and when i re-installed it nothing seemed to have changed, i.e all add on's and extensions were still in the add on menu.

I checked the firefox error console and i can see many errors including errors with my google searches and various css/html, but the details are like a foreign language to me (and i'm not a pc/coding novice), and googling for details on these errors has led me nowhere.
One of them does seem to be with regards to a download file that is missing. I checked the file (programme files/firefox/defaults/profiles) and it is indeed missing.
I did read in another forum that deleting this file and then making a new one would resolve the problem. Not sure how i'm supposed to 'make' the download file.

Any help would be much appreciated, its annoying not being able to see the status of anything i'm downloading.

Oh i should also mention that right clicking and choosing 'save page as' doesn't work any more either. This problem seems to have appeared around the same time as the download one.

Please save me before i hurt my beloved pc.
Thanks in advance
Sarah

4
Contributors
3
Replies
4
Views
10 Years
Discussion Span
Last Post by HDPfeiffer
0

I registered to this forum just to help you out. IDK if you already found this out, but either way. I had this same problem, you need to shut down firefox and locate your profile folder. The one in user/app data or whatever. Delete the downloads.rdf file located either there or one of its folders. When you start FF back up it will regenerate. and you dls should work

0

Got the same problem... deleting the download.rdf fixes it.

Thanks to ZackIsEvil!

0

Firefox did not rebuild the download.rdf file. Is there some way to now get it back? I can not get the Tools -> Options window to come either now.

-Heather

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.