W7 have weird issues with files - feeling memory ref. related


So lately I have been starting to notice some weird stuff going on with my W7 Prof.

It all started a few weeks back when I plugged in an eSata drive. When I was done with the drive I looked for the ability to "eject" it, but didn't see anything. So I simply shut it off and unplugged it. Well after I did that I checked My Computer to see the drive was still there. I thought to myself "hmm that weird", so I tried to open it and it was showing all the files and what not. Note there was no way the drive copied itself onto my main drive as I didn't have the room.

Well I had a feeling the refences to the drive were still in memory, so I tried to log off to fix it. But they didn't go away, and I had to do a full restart which fixed the problem.

Some time later (as in days or a week or two) I was trying to copy a file from one location to another, a VS2010 project from my Dropbox to its location in My Documents. Anyway everytime I tried to copy it over it kept giving me a "Try Again" message because one of the files I was trying to overwrite was in use. I thought this was weird because I was pretty sure everything was closed. So I pulled up Task Manager to check the processes, but I found nothing that showed any of these files should be in use. Well I reset the computer and it fixed it.

I then later on (I think this was after the above incident) was trying to delete the folder for Planetside 2, and it kept giving me a "Try Again" error. Now I had recently started this game up, got the launcher to realize I had to remove it to install the full version. So I tried the uninstaller and it got some error (that others seemed to be getting to), so I tried to delete the folder as instructed which as I mentioned got the error. Restart fixed it.

Well just now I was looking in a folder of mine and noticed I had files doubling up. I had opened a .txt document. Well I went back to the folder probably 5 - 10 mins later to open something else to see that there were two of that file and both of them were highlighted (as if I ctrl + clicked each), but the name was the same. A simple refresh of the folder fixed it ... the thing is I swear this isn't the first time I have seen files duplicated like this (I didn't check this time but the earlier times I want to say multiple files appeared more then once).

Now I mentioned it started with the HD, I should say that's actually the earliers I can remember ever seeing this isse, but that was weeks ago.

So I'm starting to wonder if a paging table is screwed up or something like that because it seems references aren't being discarded when something closes, and I am seeing duplicates of the same thing and it's acting if I am clicking both (well I never actually tried to click one to see if the other clicked but just seeing both highlighted).

I know that's a lot I just wrote but Googling this is proving to be difficult and I feel this is a good place to come for help.

Thanks in advance


Thank you for such a detailed explanation. Could you tell us about your computer, please? Just the type, (Laptop, Desktop) make, and model.

(a)Please have a look at your drives in 'Device Manager'
Start > Right click 'Computer' > 'Manage' > 'Device Manager' > Click on the plus next to 'Disk drives' - What who you see there? How many drives?

If you see a reference to your eSATA drive even though it's not connected, don't do anything more, just drop back in here and tell us what you see.

If you see the disk drives you know are currently installed, and there are no alert symbols anywhere then close that window and continue with the following test.

Now attach your eSATA drive and go through the above process (a) again, please. Same questions, what do you see there, how many drives?

If you see your usual hard disk(s), and now your eSATA drive, then do the following, please...

(b) Right click the eSATA drive you see there > 'Properties' > 'Policies' tab > If you see the circular options, (they're called radio buttons) click on 'Quick Removal' - if it was already set as this, which I suspect it will be, please tell us. If not, just tell us what you see.

A great feature of Windows 7 is that sometimes it just sorts itself out. If none of the above helps, then borrow a drive (a drive different to the are you used earlier) that will connect to your eSATA port. While it's connected, just do point (b) again for the sake of making sure it will accept your directly disconnecting. Close any windows that display the contents of the eSATA drive, and then disconnect it.

If none of this makes any difference, there is something else we can try. Thank you foryour patience and perseverance here. :)


Desktop, custom build. W7 Prof, i7 920, 12 GB DDR3, ext (you can find the detail on my page).

Also the eSata was awhile ago, and after I rebooted it took care of the problem. I haven't used it since as I have no need to. And just like I thought it's showing only my internal Seagate on my Device Manager.

Again the eSata was weeks ago and when I unplugged it and reset there doesn't seem to be any signs of it. Also you mentioned the quick removal option (I have looked into that quick removal and by default I think all my drives are set to that ... I would have to hook the eSata back up, but to be honest I don't think it was treated completely as a removable drive and why I just disconnected it).

I am more concerned about all the following incidents.

WHOOPS, I think there was some confusion. All the following incidents didn't happen on my eSata, but my primary internal


I have 2 issues (actually about 5) with windows explorer (WE) similar to urs and I have not found a solution.

  1. when moving/deleting files/folders the reference to the object remains in the list. WE doesn't automatically do a refresh, I must hit F5. I don't know if this is related to ur eSATA issue.

  2. When attempting to move/delete some files, or folders containing those files, I also get the msg that they can't be deleted because they r "open". If I close WE then reopen it I can usually delete the file. If it is a folder that won't delete because of a file open in it, sometimes I can delete the file from the folder, then delete the folder. Sometime I have to reboot.

The above r random, and clearly have to do with WE. It has occured on a clean installed OS. As with the other 3 issues MS doesn't seem to care or believes they r "design intent".


Sorry I forgot about this, but the issue just seemed to go away. I think it's Win 7 not updating itself (or more specificlly the GUI)

I recently did a format (cleaning out the drive), and I was having issues where my desktop wasn't showing the icon of say a downloaded object, I simply hit the F5 key and it appeared. So my best guess it it's a small bug in the Windows architecture that's not updating or something. Because after I posted this I really didn't see a problem (that I can recall), as if it just went away

(However after the format, where all partitions were removed, I swear I saw it in a folder happen once ... why I think it's the OS)

This article has been dead for over six months: Start a new discussion instead
Start New Discussion
Tags Related to this Article