Hello.

My PC (Windows 7) on which WAMP Server (PHP + mySQL + Apache) is installed is connected to a WiFi router which is further connected to a DSL Modem (for broadband access).

I've fully functional WAMP that I can access via 127.0.0.1 , localhost, 192.168.2.2 (IP assigned by my WiFi router).

Now, the address of Control Panel of my WiFi router is 192.168.2.1 (accessible via web-browsers of all devices connected to WiFi router).
- However, when a device connected to same Wifi router navigates to http://192.168.2.2/ , WAMP Page doesn't show up! but instead "request timed out" or "No Response" (on mobile) is shown.

- Also, before when my PC was connected to Internet via a 3G USB Modem, My external IP when accessed via anywhere on globe showed WAMP's page, but, now it shows my DSL Router's Admin Panel at 192.168.1.1 (which is understandable).
I tried setting up port forwarding, but doesn't work....Like i tried redirecting http://external_ip:81 or http://192.168.1.1:81 to http://192.168.2.2:80 but it doesn't work!

I need to make my wamp site at http://192.168.2.2/ accessible both LOCALLY (WLAN/WiFi) and GLOBALLY (Internet).

Any help is appreciated!

Thank you! :)

Re: WAMP Not Accessible Locally / Globally. 80 80

You can also see my previous thread at http://www.wampserver.com/phorum/read.php?2,75605
(Got no answers yet :( )

Re: WAMP Not Accessible Locally / Globally. 80 80

State your problem more clearer, i can't understand

Re: WAMP Not Accessible Locally / Globally. 80 80

Hi akshayinbox,

To start off from the really simple before heading on to the complicated, when you right click on the WAMP icon on the taskbar there is the option for put online, have you enabled this option already? This needs to be done so that the the WAMP services can be accessed on your host's I.P not only localhost.
If you have already done this, then kindly check to see whether there is translation or rules(on the wifi router and Windows firewall) that might be preventing access to port 80 on your server. You could also try changing your Apache webserver port to something like 8080 and allowing it on your Windows Firewall.


Goodluck.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.19 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.