I own Gateway computer - DX Series DX4320-19 Desktop PC Windows 7 Home Premium 64-bit. Recently my wireless internet crashed, so I tried fixing it. I had D-Link Dir-615 and when trying to reinstall it, I kept getting a message "Unable to detect wired connection. Please check the connection between your computer and the router and try again".
I checked and tried multiple times and nothing. I also tried using different cables.
So, I decided that perhaps my router is the problem and purchased a new router (ASUS RT-AC660U). So, $189 later I get the very same message.
When I skip the router and connect just throught the modem (D-Link DCM-202) the internet works no problem.
Does anyone have a solution? Is it Windows 7 that is the problem? Any and all help is very appreciated!

Thank you :)

If you connected the computer directly to the modem and the adapter works, it sounds like you just ruled out the computer as being the problem. Are you able to reproduce this issue by connecting a different computer to the router?

Thank you for responding JorgeM :).
Good point, this could be the router then? I wonder if I need to contact Asus or D-Link since it could be their firmware? The wierd thing is that D-Link Router worked before and then it suddently stopped. Now none of them work.

I would try different solutions so you can figure out what is in common. Once you can reproduce the issue and also figure out how to make it work, then it should be easy to figure out where the actual problem is.

When you say that your wireless network crashed, in what sense did it crash? What happened?

Have you logged into your Router directly to configure it? If your computer can connect to the 'net but your Router can't, then you may need to copy your computer's MAC address into your Router. In your Router's settings there will be options to provide your account details, username, password, etc, if such is required by your ISP. There will also be an option to tell your Router to use a different MAC address, one that is already recognised by your Internet service. Enter the MAC address of your computer.

So this is very wierd...I contacted ASUS - they were great, willing to exchange the router - which I don't think was an issue. However this morning, after having the router on for 2 days, not connected to the network, I plugged it in to try one last time and....it's working! Thank you everyone for responding to my post! you are very appreciated!!!!
Happy Holidays!