0

I have had the network up and running before with no probems. But now after reformatting both machines I have this annoying problem. I notice that when I click on a shared folder or drive in my network places it takes about 20-30seconds to open, yet after it's been done once it opens fine next time round (as long as not too much time has transpired). Its like the communication has dropped out & needs to be opened again or something, this does not just happen at start up but can happen when the pcs have been on for hours. Both machines are running XP & are connected via a crossover cable. Thanks in advance for any help.

5
Contributors
6
Replies
7
Views
13 Years
Discussion Span
Last Post by Silbylaw
0

Make sure these services are enabled under network connections, local area connection:

File and printer sharing
QoS packet scheduler
Client for Microsoft Networks
Internet Protocol TCP/IP

If you have all of those running you should be set...otherwise it could be a bad cable.

0

Make sure these services are enabled under network connections, local area connection:

File and printer sharing
QoS packet scheduler
Client for Microsoft Networks
Internet Protocol TCP/IP

If you have all of those running you should be set...otherwise it could be a bad cable.

He stated that it eventually connects, so the services must be running. My guesses are (1) either the NIC's power management feature has been turned on or (2) slow browser service.

For (1), check your Local Area Connection and click off "allow the computer to turn off this device to save power"

For (2), try mapping network shares using ip addresses instead of NetBIOS names... i.e. \\myserver\myshare --> \\192.168.1.1\myshare

0

I had this problem as well. I was able to correct it by disabling the firewall on both machines. Apparently the delay was because when a connection was initially established, it was necessary for both machines to make sure that the connection could be allowed and find an open port to work with. Once a connection was successfully established, TCP/IP took over :) If you try again a few hours later, a new TCP/IP connection between the machines needs to be reestablished ;)

0

I had this problem as well. I was able to correct it by disabling the firewall on both machines. Apparently the delay was because when a connection was initially established, it was necessary for both machines to make sure that the connection could be allowed and find an open port to work with. Once a connection was successfully established, TCP/IP took over :) If you try again a few hours later, a new TCP/IP connection between the machines needs to be reestablished ;)

I'll still stick with my slow browser theory ;)

given the fact that

-since both machines are connected via a x-over cable, there's no need for a firewall and most likely he didn't install one or turned Windows personal firewall on.

-XP is set to use DHCP by default and there's no DHCP server between the 2 systems. Not quite sure if the Windows auto assigned IP's are on the same subnet or not after the initial DHCP request times out.

0

You might try disabling indexing service...it caused my stuff to hang quite a bit when browsing.

0

Hi,

WinXP checks for scheduled tasks on remote machines when a new connection is established. This can take some time. It is unnecessary for most set-ups. Here is a registry hack to prevent this from happening.
Remember to always have a backup BEFORE editing the registry.
Path HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Windows -> Current Version -> Explorer -> RemoteComputer -> NameSpace. Once you're there delete the {D6277990-4C6A-8D87-00AA0060F5BF} key and reboot.

Next time you use that PC to browse the network it will no longer check for scheduled tasks before hand.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.