0

Hi, I am new to this forum, but I have a problem,and I don't know how to fix it. I recently bought a D-Link DI-504 router so that I could connect my laptop and my other computer to the internet at the same time. The Desktop is working perfectly, but the laptop keeps giving me the Limited or No Connectivity message. Also, the laptop fails to acquire the correct IP Address. I have tried the SP2 fix as well as WinXPsock, ip/release and ip/renew, checked the cables. My network card is a Broacom 440x 10/100 Integrated Controller. Any idea what the problem is? I don't want to have to buy an external network card, but is that the next step?

4
Contributors
13
Replies
14
Views
11 Years
Discussion Span
Last Post by DMR
0

no, you don't need a new card. try checking your router's wireless settings.

0

no, you don't need a new card. try checking your router's wireless settings.

A few things, one I am not connecting to a wireless router, just a normal router with a cat-5 cable connecting.
2. I did not mention in my original post (though I am starting to wonder), that I am living in Shanghai, and that the desktop and the router are Chinese, while the laptop is a computer I brought from the United States. Could this effect my ability to connect in some way?
3. I have not been able to examine the router settings yet, because the person who installed the router placed password protection on examining router settings, but failed to pass along the password.
4. When I get the password, what settings could cause my router not to communicate with my laptop?

0

is probably problem with signal of the wireless router, in router options u have the option to increase the signal try that.

0

is probably problem with signal of the wireless router, in router options u have the option to increase the signal try that.

Thank you for your prompt reply, I really am in a bind...
Also please note (as I said in my last post) this is NOT A WIRELESS ROUTER! just a normal broadband router, which connects to both computers using CAT-5 cables! Thank you.

0

Thank you for your prompt reply, I really am in a bind...
Also please note (as I said in my last post) this is NOT A WIRELESS ROUTER! just a normal broadband router, which connects to both computers using CAT-5 cables! Thank you.

hi,

i would request you to contact ur isp for new router r modem r cable, or n/w card , but thr is option in properties of lan with "show icon with limited r no connectivty unchck this box"

0

* Getting the router password would obviously be a Good Thing. Please do that.

When I get the password, what settings could cause my router not to communicate with my laptop?

The only thing I can think of that would give you that problem (assuming nothing is actually broken) would be if someone had limited the router's DHCP scope to exatly 1 client. That is, the router was set to hand out only one IP address via DHCP. This would obviously be very unlikely, though.

1. I honestly don't know if the "cultural differences" between the Chinese and US devices could play a part, but my hunch would be no.

2. Plug the desktop machine in to each and every Ethernet port on the router, one at a time, rebooting the computer each time you change ports. If the desktop can connect properly to every LAN port, the router is almost certainly not faulty.

3. Just FYI: "Limited or no connectivity" means that a network link/handshake has been established between the router and laptop, but that TCP/IP settings aren't getting correctly configured for some reason. Some ways to weed out the suspects in that area:

* Turn off the router's DHCP server, configure static IPs, reboot all devices, and see if you get connectivity that way.

* Verify the integrity of your TCP/IP stack:
- Click on the "Run..." option in your Start menu.
- In the "Open:" box of the resulting window, type "cmd" (omit the quotes) and hit Enter. This will bring up a DOS window.
- At the DOS prompt, type the following commands, hit Enter after each, and tell us the results for each command:

ping 127.0.0.1
ping localhost

* At the DOS prompt, type the following command and hit Enter. You won't see any result from the command, but when it completes, a second prompt with a flashing cursor will be displayed; close the DOS box once that happens:
ipconfig /all >"%userprofile%"\desktop\ipconfig.txt

The above command will have created a text file on you desktop named ipconfig.txt; double-click on the file to open it in Notepad, and then cut-n-paste the file's contents in your next post here. The contents of the file will give us some important details of your IP configuration.

0

but thr is option in properties of lan with "show icon with limited r no connectivty unchck this box"

That will do nothing to fix the conneciton problem, it will only hide the alert message.

By the way zygon- please try to use proper spelling and grammar in your posts here. Not all of our members are familiar with chat/IM-style typing abbreviations, and we need to provide concise, easily-understoood advice when helping others with their problems.


-

0

Thank you, I won't have the chance to check the router settings until I get the password...But here is the txt file you requested.

Windows IP Configuration

Host Name . . . . . . . . . . . . : NELLEFACE

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controller

Physical Address. . . . . . . . . : 00-0D-56-32-80-C4

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Autoconfiguration IP Address. . . : 169.254.153.7

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . :

0

OK- and what about the results of the two "ping" commands? If the pings work correctly, you should, for each command, get 4 positive replies followed by a block of summary info. If they fail, please post the output you received.

0

OK- and what about the results of the two "ping" commands? If the pings work correctly, you should, for each command, get 4 positive replies followed by a block of summary info. If they fail, please post the output you received.

Sorry I forgot to say that they both worked, 4 sent and 4 received.

0

OK...

1. The pings to the localhost/127.0.0.1 address indicate that your TCP/IP software stack on the laptop is most likely not corrupt.

2. The 169.254.153.7 auto-configured IP address means that the DHCP client software on the laptop is most likely functioning correctly, but either cannot obtain a valid address from the router's DHCP server, or cannot find the router at all.

3. Did you try connecting the desktop to all of the router's ports to make sure that they work with that computer?

4. Have you tried disconnecting the desktop and connecting the laptop in its place (using the desktop's Ethernet cable as well)?

5. Run the ipconfig /all >"%userprofile%"\desktop\ipconfig.txt command on the desktop machine and post that machine's ipconfig.txt file.

When swithing devices/cabling around, remember that for the best test of connectivity you should power down all of the device each time something is switched. Once connected power the devices back up in the order of: modem first, router second, computers last. Allow each device to complete its power-on self-test and stabilize before powering up the next device.

0

I finally had someone who knew what they were doing look at it, and somehow I was missing one of my drivers (or something like that, he only spoke Chinese and had his g/f interpreting), so it is working fine now.
I think I accidentally deleted the driver while fiddling with hijackthis... a good lesson to learn though, about not deleting something unless you know what it is.:cheesy:

0

I think I accidentally deleted the driver while fiddling with hijackthis... a good lesson to learn though, about not deleting something unless you know what it is.:cheesy:

Mmm... yeah, I'll buy that. :mrgreen:

Glad to hear that you got it working again, though; thanks for the update.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.