Hi im new to building computers I had a lot of troubles in the begining and finally got the parts to fit in the case and all of the power cables to go in. But when I put it in the case and it wouldnt start up. Thank you in advance.

Parts
Case: Cooler Master Elite 431 Plus - Mid Tower Computer Case with USB 3.0 and Windowed Side Panel
CPU: intel Core i3-4130 3.4 3 FCLGA 1150 Processor BX80646I34130
Motherboard: MSI Computer Corp. Motherboard ATX DDR3 1333 LGA 1150 Motherboards B85-G41 PC MATE
Ram: Kingston Value RAM 4GB 1333MHz PC3-10600 DDR3 Non-ECC CL9 DIMM SR x8 Desktop Memory (KVR13N9S8/4)
Hard Drive: Seagate Barracuda 500 GB HDD SATA 6 Gb/s NCQ 16MB Cache 3.5-Inch Internal Bare Drive ST500DM002
Graphics Card: EVGA GeForce GTX 650 1024MB GDDR5 DVI mHDMI Graphics Card 01G-P4-2650-KR
Opitical Drive: Asus 24x DVD-RW Serial-ATA Internal OEM Optical Drive DRW-24B1ST (Black)
PSU: Logisys Corp. 550W 120mm Ball Bearing Fan with PSU ATX 550 Power Supply PS550E12BK, Black
Ram:Kingston Value RAM 4GB 1333MHz PC3-10600 DDR3 Non-ECC CL9 DIMM SR x8 Desktop Memory (KVR13N9S8/4)

Just listing the components isn't helpful. When you turn it on, does ANYTHING work, such as fans and such? Have you verified that you plugged the power supply into the correct headers/plugs? If it doesn't even turn on the power supply fan, have you checked if the power supply circuit breaker / fuse hasn't tripped / blown?

I have built a lot of systems from components, but many people have problems doing so because they don't utilize due dilligence in making sure that all the i's are dotted and t's are crossed properly.

Edited 2 Years Ago by rubberman

I have plugged all of the cables in. The fans start working but no display shows up and the speaker dosent beep at all.

It's the problem in Motherboard. Does the indicator (power/hdd) blink? if it does, the motherboard needs to check or replace

This article has been dead for over six months. Start a new discussion instead.