After installing new ram into my Qosmio x300 the screen doesn't display anything :/

The laptop had 2 RAM sticks in it
Both of the RAM sticks were 2GB 533Mhz PC3-8500S

I took them out and added one RAM stick with 8GB 1066 MHz PC-8500S

Re: Laptop wont turn on after new RAM installed 80 80

hi, the most likely probls is that it does not detect the ram ,maybe it only sees up to 4gig per slot for a total of 8 ,did you check your manual for the correct ram layout ,and its also possibe it will not take 1066 speed ram

Re: Laptop wont turn on after new RAM installed 80 80

It doesn't say anything about the layout, only that is supports up to 1,2,4, or 8GB at 1066MHZ

Re: Laptop wont turn on after new RAM installed 80 80

You might try 2x4GB sticks of the supported types/speeds. Some systems require both slots are filled.

Re: Laptop wont turn on after new RAM installed 80 80

I tried just the one default RAM stick and it worked :/ so i dont think both slots have to be full :/

Re: Laptop wont turn on after new RAM installed 80 80

and the new 8GB ram is the right type/speed

Re: Laptop wont turn on after new RAM installed 80 80

laptop and desktops that have a max of 8gig ,have to have it the forum of 2x4 gig to work .i can find a manual online of the laptop so i have to make my suggest based on my experience with laptops and ram

Re: Laptop wont turn on after new RAM installed 80 80

Caperjack makes a good point. The use of a single 8GB SIMM would imply that the laptop supports 16GB, but you say it only supports up to 8GB. So, using 2x4GB SIMMs would seem to be a valid point.

Re: Laptop wont turn on after new RAM installed 80 80

Makes sense, at least I learned something new, so thanks

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.19 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.