0

I've owned a Toshiba Satellite L15-S104 Laptop for a couple years now, but a few months ago it died on me. I'm not all that knowledgeable when it comes to actual computer hardware, so please excuse my ignorance/stupidity. I don't have all of the machine's specs as of right now, but here is what I do know:

I was using the S-video port to watch a movie through my TV- after a few minutes it tells me the battery is about to die- when it should have been close to fully charged. It shut off immediately after the warning.
I plugged it in, but as far as I can tell, only the fan and CD drive receive power. The 'computer' shuts down(or rather, loses power) as soon as it is unplugged. I tested the power cord and it is working properly, but there is a plastic shroud on the battery that prevents me from testing it.
I've read a few sites talking about DC Power Jacks losing connection, and how you can re-solder the pin to the motherboard. I tried this, without success, but I'm guessing I have greater issues - Motherboard?!?

I don't absolutely NEED this laptop to work(since I have been happy with my new desktop), but for convenience sake it would be nice to have operational. That being said, if the motherboard is the problem, I'm interested in ANY motherboards that would be compatible - preferably something CHEAP since it won't be used for any major applications. I've tried looking for some compatible motherboards, but have yet to find any valuable information. If anyone could offer their advice/expertise, it would be greatly appreciated.

2
Contributors
1
Reply
2
Views
9 Years
Discussion Span
Last Post by techno t
0

Sounds like a faulty power rail.

Ebay could be your saviour trying to find your MB for the laptop. Gotta be the same type due to the port outs in the plastics etc.

*

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.