0

Hi all,

This relates back to the thread I posted where my mouse and keyboard stopped working:

http://www.daniweb.com/forums/thread111869.html

I figured it deserved a new post since I found out the root of the problem... and a work around.

Since connecting my PS2 controller, the problems got worse. Everything works FINE without the 360 receiver plugged in, however with the PS2 AND the 360 gamepads plugged in I can only use the basic keys on my keyboard as input to my computer (no tablet, mouse, programmable keys, etc. - the gamepads themselves even work).

I tried checking the IRQ for each of these, but they are listed under a USB controller device so I'm not sure they get one.

I noticed if I disabled my wireless 360 gamepad receiver and restarted that everything would work fine again (even with it plugged in, it just has to be disabled in windows). Once windows had started up I could re-enable it and everything will still work fine, so I've devised a work around listed in steps below:

  1. Download Devcon
  2. Write the following scripts to enable and disable the xbox 360 gamepad input receiver:

    Disable.bat:

    @ECHO OFF
    ECHO.
    ECHO Disabling 360 gamepad receiver...
    ECHO.
    devcon disable "USB\VID_045E&PID_0719&REV_0100" '<-Replace with YOUR hardware id

    Enable.bat:

    @ECHO OFF
    ECHO.
    ECHO Disabling 360 gamepad receiver...
    ECHO.
    devcon disable "USB\VID_045E&PID_0719&REV_0100" '<-Replace with YOUR hardware id
  3. Now I put these scripts in startup and shutdown events. This is detailed here but I'll list the steps I took for completions sake:
    [LIST=2]
  4. start>run: mmc (on vista its just start and then the search text area down the bottom)
  5. File>Add/Remove Snap In...
  6. Select group policy object, Add it, click ok, click ok :)
  7. Go to Console Root>Local Computer Policy>Computer configuration>Windows Settings>Scripts (Startup/shutdown)
  8. Right-click on shutdown>properties>add browse to your disable.bat
  9. DON'T do the same for enable with startup, instead add that to your start>all programs>startup folder, reasoning below.

[/LIST]

Interestingly enough if I use the startup event in the Management Console to call the enable script, I can make my mouse move for about 2 seconds before it is disabled again (guessing because its being enabled too early).

That's why I used the startup folder - so it's performed post login.

I hope this saves somebody alot of grief, and if anyone knows a better way to fix this issue then please let me know as this solution has its flaws (i.e. if an unexpected shutdown occurs I have to shutdown again anyway so the device is disabled etc. etc.).

*breathes*

1
Contributor
1
Reply
2
Views
9 Years
Discussion Span
Last Post by Slade
0

Just FYI, I was forced to format recently and even though a previous format didn't work it seemed to resolve the issue this time. I'm not 100% sure how but perhaps it was the Vista service pack.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.