0

Hi,

Have a iqon pc that was working all ok one day and then turn it on and nothing. I have stripped out everything all cards, disconnected CD_Rom, Hard drive etc and removed memory. No Beeps when memory removed ? Have nothing on the screen at all and keyboard not responding ? Tried new video card and nothing. Removed Power to the motherboard and replaced and the same ?

So no screen, keyboard, Fans do work on the mother board and back of the PC.

Any Ideas appreciated ?

Thanks,

3
Contributors
15
Replies
16
Views
9 Years
Discussion Span
Last Post by markiejd
0

If you are sure everything is seated properly then on the power supply try turning the switch off, press the power on the computer (the computer won't actually turn on), then turn the switch on, then try to turn the comp on.

0

If you are sure everything is seated properly then on the power supply try turning the switch off, press the power on the computer (the computer won't actually turn on), then turn the switch on, then try to turn the comp on.

I have tried this and still no joy. What is strange is that there is no beeps with no memory in there ? I was thinking of trying

http://www.8starshop.com/en/pc-pci-diagnostic-card-motherboard-analyzer-test-post-2.html

Any Ideas ?

Thanks,

0

Hi
Make sure you're speaker cable is pluged onto you're mobo. Then remove all memory modules and plug them into the other available RAM slots. swop them around and power the PC on after each swop.
PS: How many memory slots and sticks do you have???

0

2 slots and 2 memory sticks. With none in no beeps ?

What does the speaker cable do then ?

Thx

0

hi
The small speaker cable enables the sound lie when theres no RAM sticks in it will make the beeps. You might have removed the cable without noticing it. check that and get back to me asap

0

hgave tried with speakers and I can here them when you first turn on as if they are getting a signal but no bleeps tried boths sticks in the first slots and also new memory in this slot and also with none and nothing. Nothing on two keyboard and two screens ?

Any Ideas ?

Thanks,

0

Ill recommend you getting you're mobo checked seeing that theres no luck in what I initially thougth was wrong. The card in the link you've posted will tell you if theres problems with the mobo.
Sorry I couldnt be of more help.

0

No worries I have never seen or not been able to get around something like this before. Normally you get something. I get no screen, no keyboard no beeps to give you a clue ? I will get the card and see what this gives but I think there is a fault on the motherboard. I have tried a new video card and new keyboard and taken out the bios battery ? It has to be faulty. I cannot think of anything else ??

Thanks for your help.

0

The only last thing I can think of is whether the power supply is not supplying enough power but it powers both fans and opens the dvd when connected and I can hear the HD spin up ? What do you think.

Thanks for all of your help by the way.

0

You see thats what I was thinking of for a split second also before posting the previous post. But so I re-read you're first post to find that all fans does power up. Being so it doesnt mean that there is enough power on the system. Ill say before spending some serious money it wont hurt just to borrow a PSU of a buddy just to test it on you're mobo.

0

still nothing it has to be the motherboard. I have never had it where I get no beeps with no memory in......Thanks for your help but this one for the recycling I think.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.