0

Hello everyone! :) I had to reinstall WinXP about a week ago and everything went fine. The only thing is the CD drive is missing in my C drive and hardware device manager. I copied the following files from win 98 cd but that did not work this time. The files i copied were BTCDROM.SYS AND OAKCDROM.SYS BUT DID NOT COPY THE MSCDEX.EXE FILE AS IT ASKED ME IF WANTED TO OVERWRITE THE EXISTING FILE so left that as is. I am wondering if the best thing to do would be do download the CD driver from the internet as i don't have the software and of course i need to open the case and check brand and serial number. Any suggestions would be appreciated. Again thanks everyone for your help. I love this site!!

4
Contributors
10
Replies
11
Views
8 Years
Discussion Span
Last Post by annamaria58
0

You shouldn't ever have to install a CD driver, but you should NEVER transfer system files from windows 98 to XP. They are not the same files and even if some are interchangeable it's a huge risk.

0

You shouldn't ever have to install a CD driver, but you should NEVER transfer system files from windows 98 to XP. They are not the same files and even if some are interchangeable it's a huge risk.

Thank you for replying and letting me know but I am still not sure how to fix this problem. Any other suggestions?

0

Possible Solution.
Run Regedit and delete Upper and Lower filters -If they exist.

Backup Registry before making any changes.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

0

Hello Sparkax thank you for the tip, only thing is i don't know what an upper and lower filter is. I will try to locate it. Also forgot to mention that in Bios it reads that CD drive is not installed. Actually can't remember offhand but it either says CD drive or CD rom. Thanks again and have a nice evening. :)

Possible Solution.
Run Regedit and delete Upper and Lower filters -If they exist.

Backup Registry before making any changes.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

0

If I'm reading this right, that the drive doesn't show up in BIOS, then it's not a software issue. Either your drive or cable has gone out. I'd try swapping the cables from your Hard drive and CD (If they're the same, 90% of the time they are) and see if that resolves it, if not it's a dead drive.

0

Yes if i remember correctly in Bios it says NOT INSTALLED. I did try another Cd rom player and still same problem, i will try another cable and see if that works. Also wanted to mention that most of the times when the computer starts and i press F2 to go into bios the keyboard and mouse won't function and usually have to restart. The strange this is when i go into Windows XP it does not have that problem. Any ideas? Thank you so much for advice.

If I'm reading this right, that the drive doesn't show up in BIOS, then it's not a software issue. Either your drive or cable has gone out. I'd try swapping the cables from your Hard drive and CD (If they're the same, 90% of the time they are) and see if that resolves it, if not it's a dead drive.

0

Hi Sgamble thanks for you reply. By molex you mean a cable? I am assuming that is what you mean. Thank you :)

OlyComputers is right.

Also try a different power molex for your CDROM.

0

Thanks for all your advice guys i will try all the suggestions everyone has posted. Have a great week!!!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.