0

Compaq C500 laptop won't turn on. When I plug in the charger the charge LED lights solid for just a millisecond, then flickers.I completely disassembled the unit, down to the main board. I removed the charger port from the unit and plugged the D/C charger into the port. I then checked for voltage at the plug (that connects to the motherboard). I get a solid 19 VDC. I reassembled the laptop and tried powering up without RAM, then without CMOS battery, then without main battery. Either way I still get the same thing. I plug the D/C charger in the port and get a solid charge LED for a millisecond before the charge light starts to flicker fast. There is always a small hesitation before the LEDS flicker. Lastly, I hit the power button when the LEDs were solid and unit tries to power up. As soon as the system fan turns on, it stops and the LEDS start that fast flickering. I tried holding the power button on and then it starts flickering too, but no system fan or anything else. BTW, this is a new D/C power supply. Any ideas?

3
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by bs176sf
0

Is it the same thing with and without the main battery attatched?

I would say a faulty motherboard. Fried chargung circuit?

0

I have the same issue of my C500 not booting, but my LED indicators are different. When I hit the power button with my battery and charger connected, the power LED turns on for 2-seconds solid, then blinks between 1 and 6 times (random number of blinks over many tries). If I unplug the battery, hitting the power button causes the power LED to turn on for 1 second, then turn off with no blinking. I pulled the CMOS battery for 7 minutes to clear BIOS, unplugged the RAM, and expandable wi-fi module and tried to boot, but all produced the same issue. I also tried holding the F8, F10, F11, or F12 keys right after hitting the power, but still same issue. I also disconnected the hard drive (note that the HD LED never blinks at all) and have the same no boot issue. The LCD never comes on. Somebody else said the LCD connector could have been loose, so I still have to disconnect the internal LCD, then connect an external one, and see if that fixes it. Also, when the charger is connected, the lightning bold LED remains solid and never blinks. It always says solid. The voltage on my power supply was 18.5V, so it looks like my charger is workikng. However, does anybody else have this behavior?

0

When I removed and re-inserted the battery with the charger still connected, the lighting-bolt no longer remains solid. It now stays off completly. When I disconnect and reconnect the power supply, the lighting bolt makes one single blink for about 100ms. It no longer stays on solid with the charger connected. Also, with the battery disconnected, sometimes the power LED will stay on for 2-seconds solid, then turn off after being pressed.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.