0

Hi - just thought I'd give you my similar problem and how i solved it - might help somebody.

Firstly (surprise surprise) I have a Toshiba Satellite 1800 laptop. This came with a TEAC DW28E cd/dvd drive which stopped working cos it is crap. I bought another one this time dw224e, swapped the drives, no probs.

A while down the line I flashed the drive to rcp1 - using the dangerous brothers website I found the firmware (because of course toshiba and teac website are sh*t and don't have the firmware there). Also learnt how to do everything on DB website - which is sadly now gone.

I have all necessary files if anyone needs them - inc. boot disk flashing program and firmware for the following:

usage C:>flashe3 filename.bin [option] [option] ...
option : /ps primary / slave drive(default)
/sm secondary / master drive
/ss secondary / slave drive

/n drive CD-220E or CD-316E
/cd224eb drive CD-224EB
/cd540e drive CD-540E
/dv22e drive DV-22E,25E,28E
/cdw54e drive CD-W24E,W54E,W58E
/cdw216e drive CD-W216E,DW-224E
/dw28e drive DW-28E
default other CD-ROM
/wait:xxx wait time after flash-rom write
xxx=10 to 999(second)
/tout:xxx time-out(while BSY=1)
xxx=10 to 999(second)
/cont no [ENTER to continue] message.
/rev indicate software revision.
/? : will how to use this program

working: flashe3 nd12a0r1.bin [/sm or /ss] /cdw216e
flashe3 nd12a1r1.bin [/sm or /ss] /cdw216e

Use only one binary. One is for the regular cable select
the other for the inverse.

TEAC DW-224E-A Firmware released by NeoTek

RPC1 patched by The Dangerous Brothers

I was given 2 F/W files - one for cable select drives - one for the inverse. After deciding that my drive was probably cable select - unfortunately the files don't say which is for which!

Using the IDEDIAG command on the boot disk, i found out which IDE the drive was on. I flashed the drive and got the dreaded IDE #1 error.

After a few months I decided to have another look at it and sussed it out.

I swapped the drive with my old one to get around the IDE error on boot up.

Booted using the bootdisk

Swapped the drives again

Flashed the drive using the other F/W file - I guess the inverse of the cable select file that I used before and it fixed the problem.

If you're not as lucky as I was to have a spare drive lying around, you could bridge the pins 45&47 for the boot up the remove it and flash using the other file.

Sorry I have verbal diarhoeah
I guess what I mean to say is the solution to the IDE #1 error is:

1) TEMPORARILY BRIDGE THE PINS 45 AND 47 FOR BOOT UP
2)FLASH WITH THE CABLE SELECT INVERSE F/W FILE TO THE ONE YOU DID BEFORE

HEY PRESTO.

Hope this helps if you're still awake!
:rolleyes:

0

if you need the files for those drives and can't find them anywhere, email me:


NO SPAM PLEASE!!!!

Olddog

0

I am having the IDE1# Error on boot up like many others. Original drive, nothing changed, just suddenly started happening.

Is the IDE1' Error limited to just the drive? I only ask as I've removed the TEAC (think is't the DW28E if I remember correctly) DVD-rom and when I boot up I still get the error message...

:eek:

I don't really want to waste time trying to flash or solder my DVD-rom if it's an issue with my laptop. I've checked for BIOS upgrades and there aren't any.

Many thanks

Kev

Toshiba Satelite Pro 2100

0

I assume that your DVD ROM was connected to the IDE #1 port.

When removing the drive, you may have broken a bridge between the 45 an 47 pins?

I assume that you can't use your drive now - solution would be to flash it - it's easy enough to do. Sounds like you need to flash your drive to the inverse firmware of the cable select it was originally set to.

If you don't want to bother flashing the drive, you should try putting your laptop on standby then starting up again - the drive should now be working (although you won't be able to see it in the device manager)! Well - it's worth a shot - annoying though.

If you do have a DW28E and you want to flash it - ask me for the Firmware and bootdisk.
The flashing is a 5 minute job, but you would need to boot up with out the IDE#1 error to do it!
Trying to think of an easier way around.

Good luck

0

I assume that your DVD ROM was connected to the IDE #1 port.

When removing the drive, you may have broken a bridge between the 45 an 47 pins?

Yeah it was connected. The last time I checked, when I first power up, the DVD-rom flashes a couple of times (i.e. performs a read), and you can press the eject button to get out any CD/DVD in there. But as soons as the Tosh screen comes up and dissapears to go into standard boot, I get the IDE#1 error. I then removed the drive from the laptop and still get the same error, which seems strange.

The bridge you're referring to, do you mean on the motherboard or DVD-rom?

I assume that you can't use your drive now - solution would be to flash it - it's easy enough to do. Sounds like you need to flash your drive to the inverse firmware of the cable select it was originally set to.

I do have another laptop I can borrow (it's a Packard Bell..), so could try the drive in there (if it will hook up), and if it works flash it from that. I'll give the standby trick a go as well. Will have a look tonight and make sure I've stated the correct model of drive and then may drop you an email for the files!

:cheesy:

Many thanks for your advice Olddog

Kev

0

Ok I tried the drive in the Packard Bell and it didn't recognise it. Ineterestingly though, I could open the drive put in a CD and it the drive would perform a read on it (as pe norm).

I tried the Packard Bell drive in the Tosh, and it acted the same as the original, and the same with no drive in at all...

IDE#1 Error.

I've tried updating the BIOS through windows (wouldn't let me as I am uptodate), perhaps I'll try and do it through boot up and hopefully it will re-flash it.

If it's not the BIOS I can only assume there's something wrong physically with the laptop itself, even though for the last two years since I've had it, it's been fine and I've never fiddled with it before, both physically or playing with the BIOS.

What brand does get the least problems? Just incase I have to get a new one at some point!

:-)

Kev

0

I wanted to offer my thanks to the thread and log my configuration so future web-searchers will be able to find it in their searches.

I have a Toshiba Satellite 2455-S305 which had an internal DVD-RAM (DVD-RW) named SD-R6012. Suddenly, it was able to read and write CDR and read DVD, but got a zebra effect in writing DVD. The writing software(s) indicated no error. The zebra effect was after completion I would have an unreadable disc and reflecting the write-side in the light I could see as if the lazer gave up from time to time and gave a striping effect. Eventually it degraded to not writing at all (after finding out one hour later and seeing no case of written data) and the disk inserted into another computer would be autoplayed as a blank disc.

So, I figured I needed a new drive and I am low on desk space and USB 2.0 ports in my hub. I saw that Toshiba had produced a SD-R6112 which wrote at 2x compared to my SD-R6012. I didn't find any compatibility within SD-R6112 and Satellite 2455, but found the spec of the 6012 and 6112 on the sdd toshiba website. The dimensions and pins looked the same, so I took a chance. I looked online and on ebay. The 6012 was much more common in ebay and much cheaper, but the SD-R6112 was actually cheaper new on computergiants website than the used ones on ebay (or the ones shipped from UK to USA). I went ahead and placed the order and received it very quickly (shipped from Cali to Cali).

I undid the harness on my old broken down wife, err drive, and applied it to the new drive. Windows didn't recognise it hot-swapped, so I rebooted and saw this classic IDE #1 error. I called toshiba sdd tech support who agreed with me it should just work and referred me to toshiba computer support. They weren't able to ensure compat. and referred me to sdd support, so I explained that I'd like to prevent the snake biting his tail circle and request if it is in compatibility list. They couldn't turn up anything, but wanted to refer me to a service center.

Being that my old drive was able to be seen by windows, I ruled out IDE problems, bridge problems, and act-of-God. I declined the service center, upgraded Toshiba BIOS from 1.1 to 1.5 and was not successful in finding my new drive, although I can see it quite readily inserted into it's new home.

The next element was some specific searches to my HW config and didn't turn up anything. Finally, I decided to see what they had to say about the generic problem of IDE #1 error, especially since BIOS did indeed see something in IDE bay #1 using IRQ15. I landed on a sister thread of this where people were asking for emailed photos. There was one referral to this thread, where I excitedly saw familiar photos of my bridge and a DVD connector.

Reading through the thread and taking into account my redbull and alcohol raged shaky hands, I opted not to go with messing up the bridge. However, I did consider buying another bridge from CompUSA to mess with, but that'd take hours in this So Cal traffic, so I was intrigued by bending the pins up and sliding in tin foil.

For the next two hours I went blind doing a much different thing than I had heard would make me blind. I used some nose hair trimmer scissors (trust me, hygeine is important) to pry up the famous pins; I'll call them Beavis(45) & Butthead(47). I followed that by folding a piece of tin foil about 1" square into a piece small enough to span the distance of the two pins, but not too great to usurp the other pins.

After much time working with needle nose pliers, the nose trimmer had been put away at this point, I felt anguish and despair at my futile attempts. So now here I was folding tin foil and I felt it may be more exciting to chew on tin foil and feel that excruciating and numbing pain and I looked at the clock. The traffic was definitely subsided, but if I bought a new bridge I would be spending hours with the solder and inhaling lead fumes and making negative progress. I kept at it, and halted the red bull, and eventually I got a 1 inch piece of tinfoil that was as wide as the two pins. I tucked it under those two boners of pins (beavis & butthead). Using the needle nose pliers I bent the pins back down with the tin between them and the plastic casing. After it looked secure and was not touching the other pins (Dahreah [49] and Wilson [43]) I snipped at the one inch length of the foil to leave a slight overhang. I had used a standard pair of scissors for this activity (If you were following along, you'd have seen I had put away the nose trimmers). This overhang spread a bit when I trimmer it, so I tapered it back to an acceptable width witht he needle nose plier and then bent it down to cover the other side of Beavis & Butthead. They were effectively wearing their tinfoil hat at this time.

I slid in the bridge and plugged it into the computer. Pressed the power button and saw an absent dreaded message. When windows XP started it had found new hardware ! Toshiba SD-R6112!!!! Then found CD-ROM (same guy). After the next 20 minutes while Windows loaded all my USB hubbed peripherals drivers and autostart spam from yahoo, aol, msn, and other, I put in a DVD to burn. So far so good, I think Beavis & butthead are doing their jobs quite well.

Thank you to the thread participants!

1

Just a quick note to register my success in using the info posted here to solve my ide #1 error.

Laptop: toshiba tecra 8100
DVD-/+RW: NEC ND-6750A

Steps involved:
1. Unscrewed the top lid of the dvd-drive
2. Unlached the drive bay by poking a paper clip through the hole in the front of the drive
3. As per the first image posted by the first poster in this thread, I located pins 45 and 47 on the connector at the back of the drive.
4. VERY carefully, I used a small flatheaded jewelers screwdriver to push the pins back as far as I dared.
5. I snipped a narrow band of kitchen tin foil (3-5mm), and using normal tweezers and the flatheaded screwdriver I was able to slide the foil under the protruding pins at the back of the connector, bending the tin foil as tightly as I could around the pins.
6. Using the flatheaded screwdriver, I carefully pushed the pins into place again making sure that the tin foil did not come into contact with the neighbouring pins.
7. Looking at the connector, I saw that I had slightly bent pin 47, but I pushed it up as far as I could and inserted the bridge with no problem.

Reassembled and booted--no problems! This old laptop can even burn at a steady 6x with DVD-R!

Thanks to all here for all your tips and info!

0

I've been looking for info about my IDE#1 error and I've found this forum.

I've a problem with Toshiba portege 7220CTe and Pioneer DVR-K16. When I turn on my computer docked (dvr is in docking station) I have IDE#1 Error and winXP doesn't see the drive at all. When I turn on without station and dock it after windows loads everything seems to be ok (can access the drive, burn cds).
Toshiba BIOS is 1.80, Pioneer firmware 1.42

Do you think this solution can solve my problem ?
Thanks

0

Ok, I can confirm that it works for my hardware as well :]
I used aluminium foil and put it under the 45 and 47 pins.

Thanks very very much !!!

0

Hi Guys,

I'd just like to thank everyone in this thread for the help, tips and advice with the "IDE #1 Error" Problem with Tosh notebooks.

I followed the instructions, and "Hey Presto!" no error!

Particular thanks go to vlg466 and his pictures.

Cheers,

CJ

0

i hate to bring back an old thread, but i'm trying to bend the pins inside the drive, but have no idea how to bend them, from top to bottom, etc. I've tried with little flatheads and even a safety pin for about an hour now with no luck...

0

Thank-you, thank-you, thank-you!

Applying a tiny blob of solder to short pins 45 and 47 on a newly purchased DVD-/+RW: NEC ND-6750A got rid of the IDE #1 error. That was with a Toshiba Satellite A40 laptop that I'd been asked to fix for a neighbour. Their cd r/w had died and I thought it made sense to upgrade her to a dvd burner...should be an easy job...yeah, right!

If it hadn't been for this place I'd have been clueless :lol:

Thanks again,
Alex

0

Hey guys!!! i love this website!... soo much knowledge availiable...

I have problems with my Toshiba Satellite 2410 not able to recognise a DVD burner (Sony DVD-RW DW-56A) that was from an old Laptop that i had died...

Following the instructions on this thread i have finally found the solution to my problem!!...
Now i can burn DVDs and use it as a normal DVD/CD drive!

Thanks guys and girls! i will bookmark this and try to help others if i can!

Thanks a million,
Daniel

1

if you need the files for those drives and can't find them anywhere, email me:


NO SPAM PLEASE!!!!

Olddog

Hi'

:sad: :sad: I can't find nowhere the firmware for my TEAC DW224e-b!!!!!I've search every possible site but nothing!I am having the same problem with many others!TOSHIBA SATELLITE 2450-101 with optical storage TEAC DW224e no more functional,bought a new one(thought the same model couldn't create problems but I was wrong!!!)IDE #1 ERROR appears!!Can you help me Olddog?I need the firmware so that I can change option from master to slave.I've tried to find those pin that everyone mention but NO LUCK!!!:?:

Thanks,Herbie76

0

I have a Toshiba Tecra 8100.

Just got an APOS DW-ISD081 Dual Layer DVD Burner on eBay.
I used it to replace a Toshiba SD-C2101 DVD drive [wanted to burn stuff]

Put it in and got the IDE #1 error.
I used your diagrams of the pins and bridged the 45 + 47 pins with foil and scotch tape.
Works like a charm.

Thanks.

0

hello,

i just saw your posting on daniweb. I have the same problem: I replaced my dvd driver on my toshiba a25 with a brand new Optorite DW-ISD081, and it does not work at all.

you referred to a picture, can you please send me the picture?

Thanks a lot.

0

Thanks alot for the pin 47-45 solution.
I had the same problem with the IDE #1 error but after conneting the two pins together the DVD works perfect.

Toshiba Satellite A10
SD-C2502 DVD

0

kinda solved this problem on my Tosh Satellite S2410-303 and an HL-DT-STDVDRAM GMA-4082N drive using an aluminium foil between 45 and 47. Only issue remaining is when I do a cold startup i.e. off -> on I get the IDE#1 error, however when I press CTRL+ALT+DEL the very next instant and the machine starts up again the drive is detected and everything is hunky dory. This should suffice for me since I am resuming my laptop more often then doing a cold startup..

Been on a bit of buying spree with odd drives and have a couple spare now.. oh well.

If anyone needs it the following are alternate drives for this laptop which I gleaned from the service manual ..

DVD ROM Drive
=============
Toshiba SD-C2612
TEAC DV-28E-B34
HITACHI GDR-8081N-ATABB0

CD Drive
========
TEAC CD-W28E


MultiDrive
==========
TOSHIBA SD-R2212
Matsushita UJDA730/UJDA740
TEAC DW-224E-34

Cheers

0

Does connecting pin 45 with 47 solve the problem alone or do I have to flash the drive aswell?

I need my drive tonight so I would be really greatful for a fast answer.

0

Hello, I have a Toshiba Satellite A25-SD279 with both Windows XP and Ubuntu on it. I bought a DVD-RW burner combo (P000366780) and as soon as I tried it, the computer gave me the Error #1 message and my only option with windows was to reboot. I could enter into Ubuntu except that it couldn't detect the drive. I used the advice posted in this site about joining pins 45 and 47 with tinfoil. Since then, Ubuntu recognizes the drive and it seems to be working fine. The problem is that I still can't go into Windows since it keeps giving me the Error# 1 message even when I stick in the old drive. Any ideas of what could be going on? Could I need a new driver or an update or the firmware? It seems odd that Ubuntu can detect the unit without any trouble whereas windows can't, maybe something got messed up when I put in the drive for the firs time...

Help please

0

Hello, I bought a new Apos DVD-RW and my Tecra TE2100 didn't like it, The IDE #1 Error :(
I bridged pins 45 & 47 with a thin wire (placed between the pins, and tucked the strand end under the socket, and dabbed with rubber cement to hold in place) worked well and the error went away and so did my sweats!! Thanks for the tips, Paul

0

IDE #1 issue

Having a problem with a Toshiba A-45, Changing out CDrw/DVD rom. This bridge that I read about (pin 45-47)is this a quick fix or is this a temp by pass. Dose anyone have a pic of the foil in place? Unsure and could use visual.
Thanks up front for any help.
tired

0

i just wanted to add that i have an acer laptop and put the APOS DW-ISD081 drive i got off ebay in it and could not burn dvds with it nor could i burn regular cds in it. I did the mod as posted here and it worked great for my acer as well. Thanks a lot

0

i just wanted to add that i have an acer laptop and put the APOS DW-ISD081 drive i got off ebay in it and could not burn dvds with it nor could i burn regular cds in it. I did the mod as posted here and it worked great for my acer as well. Thanks a lot

how do you know which pins are 45 and 47?????

0

Thanks for this great info 45+47 pins!!!!
I have solder on teac dv-28e and matsushita ujda 760 ,what says ,WORKS like charm......Thanks

0

teac dw-224e b firmware for fujitsu lifebook n6010
cant find a download anywhere please help asap

0

Hi everyone,
Is there any special procedure to follow when opening a toshiba satellite 2400-S201. I tried but its very stiff, i do not want to break anything.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.