0

READ IT ALL BEFORE YOU START
**************************

A possible workaround for the IDE #1 ERROR when using a Cable select (CS) drive in a Toshiba laptop.

Once this modification is carried out the drive is accessable for flashing as a master/slave or region free (RPC1) subject to the F/W being available for your drive (CHECK FIRST).

This information is compiled from several sources and my experiments to try and help others but I am in no way responsible for it's final results, it worked for me when the so called experts on a laptop forum and the like wouldn't help, even though claiming to know how it's done (must affect national security or something), tossers!!!
Hey they are my drives so if I stuff it up it's my loss.

*************************
When I installed these type of DVD drives (Toshiba SD-C2402 & SD-C2502) I would get the IDE #1 ERROR at bootup but the drives still functioned in most versions of Windows with no detectable problem?

But when I tried to flash the firmware I would get error messages like the following:

00 Master Not ATAPI device
01 Slave Not ATAPI device
Secondary:
02 Not connected
03 Not connected
Terciary:
04 Master Not connected

and

Drive not connected or open Etc. Etc.

I found a possible fix that entailed booting from a bootdisk FDD containing the firmware upgrade with the HDD removed which is supposed to not give an error but find the DVD/CD-ROM etc. but this didn't work for me, worth a try though?

**************************
Solution.

**See diagrams**

This is how I did it: find contact 47 (next to 49) on the DVD side of the IDE connector and bridge it to contact 45 with solder or a wire.

Someone elses explanation

1. Take the DVD out of the laptop and find the 47 contact on the IDE socket
2. Take a 300 Ohm resistore and solder it to that contact
3. If you connect the other part of the resistor to the case (ground) the drive becomes master and if you solder it to the +5 volt the drive is found as slave


I also came across information stating that a resistor is not necessary and I actually found that after flashing I no longer needed the modified connector/interface as the flashing solved the problem?

I then purchased a used CD-ROM drive just for the unmodified connector to use on my drive and I now keep the modified connector for flashing purposes only, I have since sold the bare drive I bought for more than I paid, the connector thus cost me nothing :-).

****************************

More information on the flashing firmware?

The original Toshiba firmwares are the one with 10xx and 17xx

If you have a drive with firmware 1511 then the M/S setting in this firmware is set to be Slave. But when you flash with firmware 1711 the drive set to Master.

***********************************


A few questions I asked the expert (Hijacker):

Q1. How can I tell if the DVD drive is master or slave now and what should it be? I assume the HDD is primary master and the DVD is on the secondary IDE controller.

A. Not sure about this. Actuatly it doesn't even matter.

Q2. Now that the drive is flashed/updated should I undo the modification to the IDE connector?

A. No. But you can flash it to original Toshiba firmware wich starts with 10XX and 17XX. One of these ones is master the other one is able select. I don't know which is which.

Q3. What did the IDE connector modification do, change the M/S setting thereby making the drive flashable?

A. It changed the signal for master/slave.

Q4. Does the 1D13 & XD23 firmware make the drive master or slave because the example below doesn't help me:

A. "You have a drive with firmware 1511. The M/S setting in this firmware is set to be as Slave. But then you flash with 1711 wich has inside the firmware the drive set to Master",
As I said before. I am not sure wich one is which.

**************************************************
If you have other drives you wish to use in your laptop ie. CD-RW, CD-ROM like me then you may have to get another connector or only carry out a temporary modification till you have flashed to master/slave on the CS drive.

**************************************************

Links:

Drive info Utility from the Guru:
http://hijacker.rpc1.org/discinfo/

The firmware updates by brand:
http://forum.rpc1.org/dl_all.php

**** NB. CHECK YOUR FIRMWARE UPDATE AVAILABILTY *****

I have tried to attach the jpeg files to this post to help explain the procedure.

Attachments assembly.jpg 7.93 KB dvd_connect.jpg 51.95 KB dvd_drive1.jpg 23.34 KB laptop_connect.jpg 42.5 KB
52
Contributors
59
Replies
65
Views
13 Years
Discussion Span
Last Post by kamwi20
Featured Replies
  • Just a quick note to register my success in using the info posted here to solve my ide #1 error. Laptop: toshiba tecra 8100 DVD-/+RW: NEC ND-6750A Steps involved: 1. Unscrewed the top lid of the dvd-drive 2. Unlached the drive bay by poking a paper clip through the hole … Read More

  • [quote=olddog;203042]if you need the files for those drives and can't find them anywhere, email me: NO SPAM PLEASE!!!! Olddog[/quote] Hi' :sad: :sad: I can't find nowhere the firmware for my TEAC DW224e-b!!!!!I've search every possible site but nothing!I am having the same problem with many others!TOSHIBA SATELLITE 2450-101 with optical … Read More

0

I need help with this one, I have the SD-C2502 with the X011 firmware
in it, but it has been set to master and I have tried to us the VUP100k.exe program but it keeps coming up error just after i say yes to it flashing the bios. and it puts up something about NON STOP Eject or something like that.

Please help I'm stuck, I need this drive to be slave it does not have a PCB on it it just goes onto the laptop

0

What I did to fix the ide #1 error
**************************
Model: SD-C2502 1313
Toshiba sattelite pro 6100
Windows xp pro

I tried to flash it to make it region free, but used the wrong rom version. Bios couldn't detect drive.

1. Found the correct firmware for my drive, SD-C2502 1313.
2. Formatted an 3,5" ms-dos start-up disk in Windows explorer.
3. Copied the firmware files to the disk.
4. Shut down.
5. Removed the dvd player from the laptop. This way I didnt get the ide#1 error on start-up.
6. Booted from the 3,5" start-up disk.
7. Put the dvd player back in.
8. Ran the vup100k 1313b.hex programme. Bingo.

0

When I using Toshiba DynaBook (G6C/X18PME japanese) without or with the Panasonic UJ-811 DVD-R/RW/RAM drive IDE #1 ERROR occure.

0

Same problem here, with a Satellite 1800-S253 and the Toshiba SD-c2502 (FW version 1313). Firmware flash and boom.

I have tried ketil's method of removing the drive, booting, re-inserting and flashing, but strange enough, the IDE error stays even once the DVD/CD drive is pulled. Any explanations for that one?

I have ebayed a replacement drive (this time it is FW version 1513), but same thing: the BIOS doesn't recognise it.

I will sneak around the BIOS a little more to see whether I can set IDE configuration differently, but I couldn't find anything at first glance. Secondly, I have read somewhere that a guy woke up his drive again by disabling IDE 2 in his Windows settings.... Wow. Gotta try. Last resort is manipulating the IDE connectors as described above - I just fear that's going to be a mess...

0

Hey guys you sound like real Laptop Gurus,
anyway I had this problem with my DVD drive (SD-C2402) in a
Toshiba Satellite 2710DVD, my DVD drive keeps blinking everytime I turn on my computer, back in Vancouver a so-called "Toshiba Certified Service Technician" repaired my laptop as he claims by replacing my DVD drive with a new one, I believed him at the time because I had not opened a lptop before but now that I have done it after moving to Ontario, Canada I come to realize taht maybe my laptop still has the same DVD drive. I dont believe it laptops have quite a simple Plug and Play structure inside, I payed $400 for. The technician temporarily fixed it some way I get the same problem again now, I come to realize maybe its not the drives fault.

#################################
When I restart my computer..the "TOSHIBA" thing in red stays there for about an hour, while my DVD drive keeps blinking, then about 7 minutes later it moves on to saying IDE # 1 Error at the top left hand corner ( DVD Drive still blinking, not ejecting ) and When the computer is done booting up the DVD drive is still blinking and there is no CD/DVD device detected by my laptop.. no mention in the Device Manager or My Computer.

Guys Please help me out with this,
I am not aware of the term "Flash it".
Please tell me how to fix this in the simplest words.

fizzyboy88

0

I would have one ask I have a CD Rome TEAC 224-B and have myself from
e-Bay the plug-in module bought with to switch on in my Toshiba Tecra
8100 drive that to laptop no longer highly only if I CD Rome drive
assembly out-put and then again clean-put functions it otherwise get I
the fehlmeldung IDE 1 # error. I have determined this module with the
pin 47 + 49 soldered am. That is to actually origin-be entitled which
happened if I this soldered connection would take away

0

After a year in the cooler, i took back my missflashed DVD rom drive.

Toshiba Satellite 1805-s203
Unit: TOSHIBA SD-C2502 with Rom ver 1313

One year ago, I missflashed the unit and i didn't find the way to make it live again so i took off the part from my laptop so it could start windows faster than it did when the missflashed dvd was connected.

So this time i took some time reading the posts of many people and found the solution. You know a lot has been told about the famous pin 47 and 45 bridge connection.

Well here it is, you don't have to buy an IDE to LAP CD DRIVE connection or anything, the only thing you need is:

1. A tiny screwdriver X preferred
2. A piece of copper wire or another tiny wire (as thin as a hair) like 1cm long

Step by step.

NOTE: You don't have to find your original firmware, it's restored after the operation to RPC-2 With region code locked as originally was- Your computer must be off!

1.- Lift the plastic plate with the INTERNET and APP1 APP2 buttons with pressure
2.- Take off the 2 screws in the top of the keyboard
3.- Lift the keyboard and you'll see if you pay attention right under the letter "K" of your keyboard when you lifted it a screw that you have to take out and another screw you have to take out its the one just up the "F9 and F10" keys.
4.- Pull out the case of the DVD drive
5.- Remove the upper case of the DVD drive (3 screws and 2 at the back)
6.- In the back part of the DVD Drive its a tiny hole that you have to pull down a little "thing" that makes the dvd case come out
7.- After you've done all that YOU HAVE TO CHECK THE SCHEME JPG. wich is nothing but the pins name that you gonna use next
8.- With a flat screwdriver you have to pull back the pins 47 and 45 so you can attach in the back of them the piece of wire to make a bridge between them. (THIS MODE SETS YOUR DVD TO SLAVE)
9.- After that you have to close the dvd case and put it again at your laptop.
10.-Turn on your computer and as you can see by the time it takes to load windows your DVD is now back to life and restored with maybe 1 or 2 hours of work instead of buying a new one.

NOTE 2: If you missflash your drive again it's easy to make it live again, all you have to do its take the wire out and it's set back to MASTER

and again if you missflash it PUT THE WIRE AGAIN AND ITS SLAVE and again again again again.

If you like animation as I do, check my website:
http://www.opower.net

Thanks
Eduardo Altamirano
Mexico DF

0

Excellent work, buddy.

100 time THANK YOU!!!! :!: :!: :!: :!:

I have TOSHIBA DVD on my notebook and i flashed him (obviously wrong),
afther that i received msg. IDE #1 ERROR...and cant install nothing....

DVD doesnt working, i cant install win/linux...i was desperate...and thinking
(last solution) to take my notebook to the service centre. But I know how
much expensive they are, and long time to finish their work.

So, started to search on the web something about this problem, and find
this forum, and your scheme and manual what to do.

Coz I havent nothing to loose, i took screwdriver and start digging.

After 2 hrs sweating, and trying to connect those two pins, finnaly made it.

I was connect them, and for first time bios reccognized my DVD and I was
able to flash him again...then normally boot (install system again)

:lol: :lol: :lol: :lol: :lol: :mrgreen:

Once, thx for instructions.

Bye,

chawka

0

If you have missflashed your Toshiba DVD and you live in Mexico City, I can fix it up for you. I'm the one that posted the solution.
Si vives en la Ciudad de Mexico y flasheaste erroneamente tu unidad Toshiba de DVD, puedo arreglartela, solo contactame.
Contact info:
tel 52560022
Cel 0445585618662

0

I have a Toshiba SD-C2502 DVD-ROM ver. 1011, which is set to Primary and I need to change it to Slave but I'm not comfortable doing it by soldering connections so I'd prefer to change the firmware. Can anyone tell me which version firmware I should use for this. The drive is for use in an IBM i-series 1200 laptop. Any advice would be appreciated.

0

Hi, I have just recently joined the forum because I have experienced the same IDE # 1 error problem. I have bought an SD C2502 DVD drive through ebay and I could not tell what version it is because that part of the label is missing. When I installed it to my laptop, I got the IDE # 1 error. My questions are, Is there a need to flash it? and Is there a way for me to know it's version so I will know the kind of firmware I would need? Thank you very much. I hope somebody out there can help me :rolleyes:

0

My experience with the ide #1 error
**************************
Burner Model: NEC ND-6500a
Notebook: Toshiba Satellite 1800-814
O.S.: Windows xp pro

1. Prepare the notebook removing the screws that blocked the DVD reader
2. Start the computer with the DVD Reader, stop the booting sequence (pressing F12), you'll obtain a screen in which you have to select the boot device. Before doing it, remove the DVD reader and insert the burner
3. Boot from a floppy containing a DOS that recognizes CD and start launching 6500BOOT.bat (contained in the 6500Boot.zip at http://www.cdrinfo.com/forum/tm.asp?m=84345&mpage=1&key=)
4. Restart, doing the DVD change as in 2.
5. Launch 6500MAIN
6. Restart with the ND-6500 inside....no more IDE Error, Windows Xp sees it, everything works

I hope that it could be useful for others.

0

Thank you very much! I will try to follow your instructions.
More power to you! :D

0

Thanks for the thread; it helped me solve the IDE #1 error on a friend's notebook (Toshiba Satellite 2250CDT). It also had another benefit that nobody else has mentioned -- namely, the HL-DT-ST GCC-4240N DVD-ROM/CD-RW drive wouldn't operate in DMA mode (just PIO) when it was detected by Windows XP as the Secondary Slave (pre-modification). After modification as Secondary Master it enters DMA Mode 2 with no problem! This was the real issue I was trying to resolve (playing DVD's in PIO mode on a 266MHz Celeron isn't feasible), and I'm happy to say that bridging pins 45 and 47 solved it!

Chris

0

I am bit of novice at fixing my own computer. I do have the IDE #1 error, but I didn't get it by installing a new cd rom drive. It occured with me, when I installed the factory hardware in order to get it ready to sell to someone else. I have a Toshiba Satellite 2400 S201 and I don't know how to get to the motherboard in order to make the repairs that you all have suggested. I don't even know how to reseat the DVD/CDRW drive.

Could anyone please explain how to one or both of these. I think I might have to just reseat the CD ROM drive.

Thanks

0

This iswhat toshiba have to say on the subject.

It means the drive was not purchased from Toshiba Direct and it
does not have Toshiba firmware, it is probably a drive with generic
firmware. They can be put into an external case and work through a USB
but not internally in the laptop.
Thanks,
Toshiba Technical Support

0

The thing it I bought the laptop from CDW and it is the cd drive that came with the laptop, so it isn't a generic cd rom drive. Any other suggestions?

0

Hi everyone! I have followed through on this thread because I was expecting to face the same problem.
I bought a Sony CRX830E CDRW/DVD drive to replace a Teac CD Rom in my Toshiba Satellite 1410,which frequently refused to start unless reinstalled.
I tried all the software work arounds suggested to no avail- swapping drives in mid boot worked for the session but failed on restart.
So it was break the seal, open the CRX830 and look for pins 45 and 47 on the connector which was OK but much too small for my old eyes and hands to solder! I managed to push back the pins and wrap a small strip of aluminum foil round them, reseated them and replaced the drive cover. Plugged in the drive. booted the laptop and it works fine !(I reckon my solution can handle 5 volts. but time will tell if its permanent.)
The Sony CRX830E now shows as Secondary Master as it should, but I dont know whether it was Cable Select or Slave before.
I thought my experience might be of interest, but I do want to thank you all for your suggestions, explanations, thumbnails and links which gave me the confidence to attempt this operation.


Kind regards to you all. (Junior Senior)

0

THANKS EVERYONE. I FIXED THE ERROR I HAD. I HAVE A TOSHIBA TECRA M2 LAPTOP AND I CHANGED MY DRIVE TO A 'TOSHIBA SD-R6372 DVD-RW'.

I THEN HAD THE 'IDE#1 1ERROR'. AFTER DAYS OF SEARCHING FOR SOLUTION.

I PICKED OUT THE PINS 45 AND 47 ON THE DRIVE, SLIPPED SOME ALUMINIUM FOIL (KITCHEN FOIL) BETWEEN THEM, CONNECTED IT UP AND BYE BYE PROBLEM.

I LOVE MY DRIVE AND MY LAPTOP. I WOULD LOVE TO HELP MORE PEOPLE SO EMAIL ME IF YOU NEED TO
HARRY_400@HOTMAIL.COM

0

Since I'm not able to hot switch in my Toshiba Satellite M30, the only computer I can use to fix the 6500A firmware for my M30 is an old P3 machine running Windows 98SE. The original available IDE configuration was two optical drives installed as master and slave. I removed the cable and power from both of them and using an IDE adapter I connected the 6500.

I booted from a floppy and was able to run 6500BOOT with no errors.

I booted the P3 machine again from the floppy and ran 6500MAIN. Part of the way thru the batch file, I got an "error on drive A: -- Abort, Retry, Ignore or Fail" message. I assumed the floppy was bad so took it to another computer which said it was OK. I made a new floppy and got the same result.

I assume there is no firmware in the drive if I correctly understand how 6500BOOT/MAIN work. So I've got the 6500 with a flashing LED and don't know what to do next.

I could use a little advice.

0

is this modification specific to Toshiba laptops, cause I have an HP omnibook with a similar issue. Drive is C2402 (CSEL) laptop wants master/slave. BIOS won't see drive, windows will. I'm considering applying the modification to the pins, but I don't wanna fry my machine.

thanks

0

WOW You Guys Are The SH%^ Thanks SOOO VERRY Much for posting this info i had it done in less the 10min and now my CDRW/DVD Combo Works Great and by the way i have a Tecra A1 and got the damm IDE#1 ERROR

Thanks Again
Gage

0

Thanks so much! You guys are the best!

I was so frustrated with setting up my new SDR6472 in a Toshiba Satellite 1410. It just wouldn't work!

Soldering did the job!

Thanks again!

0

Hello

I have the same problem with a Toshiba laptop 2410 s515 and a sony CRX830E

I know not a lot in hardware and dont speak english fluently
and cause the only jpeg which is familiar to me is the "dvd_drive1.jpg"
I would like to know if the pins I have to link are on the upside part and inside the IDE socket or on the printed circuit card, on the side I can see without open the drive or, always on the printed circuit card in the back of the socket once I have opened the drive; those ones are in silver colors.

I know it looks like a silly question but I discover hardware from inside and wouldnt like to make mistake.

0

Thanks to the original poster.....i performed the jump from pin 45-47 and my problems were solved. I have a Toshiba 6100 and used a LG/Hitachi DVD Burner and everything seems fine now, DMA on the IDE channel is working now.

Only if there was a firmware or program that can change the slave/master setting.

Thanks!

0

help me!!!
my dvd toshiba sd-c2502 fir 1711 is died after firware update from 1711 to x711.
how I can make to repairs it? it does not come more recognized
excused my English. I am Italian

0

OMG, i finally fixed it with the tin foil fix between the pins, it took 2 hours and alot of swearing to do it but i finally did it

I was working with a toshiba satellite 1800-s254 with a sd-c2502, i took the drive out (2 screws on the inside labeled b5.5) and slid it out, got a little 1 inch square of tin foil, folded it unti it was thin enough to slip into it, curved it around pins 45 & 47 (roughly) insert it, and it detected the next time i started it up, but then i went to the firmware flash page, flashed it, but then an error happened and it completely rendered it useless again. SO i had to do the whole thing again, this time not flashing it at all, just letting it be, and yes now it still cant play dual layered dvd's, but at least its reading cd's and some single layers again.

The only reason why i used the tin foil fix is because my soldering iron was on the fritz and the super small screw driver i had the tip was worn and i couldnt grip the small screws on the dvd drive, so i said the hell with it, should have the same effect because it is just shorting out the 2 contacts, and sure enough it did work, so after about a week of being dead and slowing down my boot up with the ide error message, i fixed it, and whats odd is that even after removing the drive and booting it up, it still wouldnt boot fast because the ide error was still coming up..... odd....so yeah if any one needs further instruction or more detailed info on how to do the fix, just pm me or reply to this

-Sackavelli

0

hi all.
nice idea with the pins, to make the new drive work.

BUT WHY IS MY OLD DRIVE NOT RECOGNICED ANYMORE?

my standard text in all forums i found is:
i have the same prob:
old teac out, new one in (same one) -> IDE error
old one BACK IN - > also IDE Error now that was not there before.

Toshiba site and support is crap, some other partner meant that
a) IDE controller could be dead (why is then my HD still working?)
b) the drive connection could be not 100% (but it has power and opens etc.)

i can not flash the new drive to slave cause it is not recogniced at my laptop, i dont have an adaptor to connect to desktop. but even if i could flash it right, like my old drive is already, it would not be recogniced i guess....

what do u think?

bios settings are not accessable (on my toshiba satellite pro 2100 and i dont know how to check if the IDE controller is broken or how to read errors out of it)
do I need to solder two pins in my cd drive and everything would be (slave) better?

thanx for all answers (if there are any ;))

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.