Newbie hades here.

My second-hand Presario F730 seems to have killed its power jack; the typical home handyman, I ordered a new power jack board, tore the machine apart (actually following directions from the repair manual, available online), and plugged it in. The new jack glows properly. Of the 3 LED's on the front, the one indicating charging blinks on and off. I can't tell whether the battery is charging.

When I try to start the machine, the only sound is one quiet click. The "on" light blinks for half a second, followed rapidly by a blink of the disk light. Period. End of story. No sounds of disks or fans, no lighting of the screen.

I've rechecked the connections, to the best of my ability - but I can't be absolutely certain I didn't mess one up. I've tried swapping the RAM in and out, trying on only one RAM (both units).

My best guess is that this amateur wrecked something in my messing around. Any advice, besides buying a new laptop?


Recommended Answers

All 16 Replies

I have Compaq Presario f700 which does the exact same thing, but I haven't resoldered anything. I have changed the memory chips, changed the wi-fi, changed the hard drive, and have tried a different motherboard. I assumed that the power button and cable are OK because the little neons blink on and off as you decribed. I have not tried exchanging it (the cable), the system fan (which doesn't try to spin up when the lights are blinking; neither does the hard drive), or the lcd. Did you ever discover what your problem arose from? I'm very interested in trying to get the computer fixed.

There seems to be a lot of F700s doing this. I have one from a customer also. I've completely disassembled it and put it back together (no spare screws!!) but it still is doing the same as 'chaimaker' and 'jackleg' describe.
I'm guessing the motherboard croaked.

I have a compaq f759wm. the only light that will light up on mine is where the plug plugs in. It won't power up or even flash the power light. It just quit. If any of you can explain this please help. I can't even get any results when I try to run off the battery or with the ac adapter. The only upgrade my computer has is a factory authorized RAM upgrade. Just like most of us though, my computer is 2 years old and the warrenty is no more. Does anyone have a clue cause honestly, I don't.

I had the same problem. I red on some sites, and I apply what they say, and it's working!!!

What I did: press ESCAPE and then POWER ON, with Escape pressed. The laptop on, but the display still off. After few minutes of working in this way, I shuttung off. After 3 aor 4 minutes, I try to power on, and it's working fain.

If that is not working to you, try this:


I have a user's laptop that is doing the same thing. I got a crazy idea and gave it a shot and it worked. Here's what I did -- with the power cord plugged in on both ends, I removed and reinserted the battery. Then the power button lit up and I was able to turn on the laptop. Of course, when it happened to me previously, just leaving it sitting for awhile was enough to get it to work as well, so this may have just shortened the time it took for it to work. In any case, it's something that might work for you too.

If anyone ever figures out what's going on, I'dreally like to hear about it.

Has anyone figured out what is going on with this model? Mine is doing same thing and I am really frustrated.

My adapter cord was frayed when the problem happened. Removed battery, loosed power cord, held power button for 20 secs. Reconnected new power cord and it booted up fine. Upon reboot, it did read a message that it shut down because the battery was "critical." Have not reinstalled battery... may try tonight.

I'm still looking for the solution for black screen problem.
I can't help you but provided my experiences for a month I tried.
Any Fn keys, Esc...didn't change a thing but a towel trick solved my on/off, on/off...problem. however some guy warned it is not good for CPU.
if you desire to solve the on/off problem like me who has nothing to lose, then you can find the guy post in "free fast fix for hp tx1000 no video or boot".

I had the same issue. I completely disassembled my laptop and removed the motherboard as well as the small CR2032 battery. I ended up heating up the backside of the GPU using a portable work light and re-seating it. I did protect the other components using a cardboard and tinfoil heat shield. After re-assembling it the laptop has worked flawlessly for multiple on/off cycles and application upgrades. I can't say for sure this is the solution for all but it saved me. You will want some thermal adhesive on hand to re-set the GPU and CPU to the heat sink. This was the first time I have ever disassembled any computer so if you are at wits end, it is worth a gamble.

I have fixed 3 of these compaq f700 laptops all with same problem.lights come on for 2 seconds then go off.clicking noise if fan starting and stopping.its the gpu graphics need to remove the mother board and power it whilst pressing hard on the gpu.if it works then you need to reflow the gpu bga chip with a heat gun...make sure you protect all other components around it with foil

I have a dead presario as well. I did all of the repairs as stated above several times. Finally I held ctrl alt delete down as I pressed the power buttom, multiple times. All of a sudden I could hear the hard drive turning, then it stopped while the 3 blue buttons were lit up. It kept powering down like before. I continually did this over and over and over and finally it cam back to life. First it came back in a setup mode similar to black and white DOS prompts and I pressed F1 when prompted and in the end my presario is running perfectly.

i fixed mine by totally removing the motherboard and components and wrapping the board with foil and cutting the foil away from the nvidia video gpu. heated the gpu with a hair dryer for approx 3 minutes on hi heat unti it was too hot to touch with fingers.....used a cloth to firmly press on the gpu and resflow the solder underneath it to reattach it to the motherboard more securely......replaced the heatsink paste and laid a small copper shim on top of the gpu......removed the factory foam insulator that was used on the gpu heatsink and let the copper shim do the dissipation of the heat combined with the heatsink and cleaned the processor fan very good and before reinstalling the mb totally in the case i tried it out and it actually came on without a hitch....good graphics and nothing seems out of whack.....totally put everything back together and now the laptop works better than it did when bought new.....this was a design flaw in laptops using the nvidia gpu. mine started all at once cycling on and off with no video but when i pressed esc it would stay on but still no video...after researching online i tried the method i explained and presto it works


I have a Compaq f700 Laptop; it's a little over a year old (which means my warranty is up and I have to pay for tech support) so I was referred here by my co-worker to ask the question that follows:

Like I said it's about a year and a few months old and I have run into the problem that when I go to turn it on-the light will flash as if it will boot up but it shuts right off. This happens whether it is plugged in or not. What do you think the problem may be? Thank you for all of your help!!!

Thanks "slayacer" That repair tip for F700 worked like a charm. It runs better than ever.

Member Avatar for Fendawg

Thanks "slayacer" you are the man, that fix worked great!
The Compaq Presario F700 lives again.

Mine won't turn on either can you help? I've tried everything and I don want to go inside of the laptop besides the hard drive and ram

commented: After you reach your limit, you take it to a repair shop. +12
Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.