0

I am desperate. And stubborn. So when I found a gutted Presario desktop at our dump, I jumped for it. Normally, I just don't bring home used electronics, but a gleaming 2.5 Ghz Celeron caught my eye.

I ran home and turned it on.
Or tried.

Computers are not meant to be left in the rain, especially with one side of their case open to collect the drops. In truth, all of my issues could be due to water damage. But I am stubborn and I refuse to believe that I must pay to junk an already junked computer.

I do know a little more than a bit about computers- enough to know that plugging in wet circuit boards that carry 250 watts is a death wish. I thus waited patiently for several hours while my new find dried in front of a fan. I am 99% sure that there was not a drop anywhere.

So when I went to plug in the beast for the first time, I did it as-is. It WAS scrapped so there was no hdd, no RAM, just a processor, Bestec psu, motherboard, and a floppy drive (no one loves floppy disks anymore...).

It was quite anticlimactic. Nothing happened. The psu turned its one green light on, so I know there was power getting to it, but no fan, no motherboard light, and no friendly beep. I pushed the power button. A lot. Still nothing.

More importantly, there was no BIOS screen; if I understand correctly, even without a hdd or RAM, there should have been some BIOS version.

So I did a bit of research, and eliminated a few things. As it stands now, this is what I have:

-Bestec ATX-250-12Z that DOES work when green is shorted to black. The motherboard is ATX so shorting the psu is the only way to manually get power out of the psu. When I did this, the CPU fan spun and the psu fan did likewise, but these are hardwired connections on the motherboard, not the board actually doing something
-a gleaming 2.5Ghz Celeron processor that has just been cleaned with a rubbing alcohol. I also checked the socket- it was free of water
-newly installed CMOS/BIOS battery; i.e. BIOS has been cleared and the right battery at the right voltage is clicked in.
-no hdd, but when tested with one it made no difference
-no RAM, but when tested with 512M it made no difference
-a mysterious motherboard with no scorches, chips, dings, scratches, or other wear. There are service tags (long void) but I couldn't find a marking on the brand.

Note that the unit was not tested with the new CMOS battery AND the RAM/hdd- this is my next check (it involves taking apart the computer I am currently typing on).

As a final clue, when I plug the psu into just the wall and the motherboard (I DID plug in both connectors), there is an infinitesimally small crackling. There is no smoke or steam or smell of any sort. It might just be a candy wrapper in my room. BUT it seemed to come from the piezo speaker. Before when I said 99% sure it was dry, the piezo speaker is the only 1% that cannot be fully checked (water can get inside). Even so, BIOS should load or at least the motherboard's light should come on.

I understand this is a tough question, but I really think that this hunk of metal still has a bit of life. Thank you for responding with whatever help you can give.

3
Contributors
11
Replies
12
Views
9 Years
Discussion Span
Last Post by Josh Connerty
0

I would first suggest taking the motherboard out of the case and connect JUST the PSU, this should make the MOBO light turn on, if it doesn't then this is a faulty motherboard. The mother board should keep beeping because there is no RAM in place.

And as far as I know the MOBO wont run the BIOS if there is no RAM present.

0

I would suggest testing the voltages of the PSU. You must have heard about all those E-machines that died, they were all fitted with the Bestec 250watt PSU. There are now tens of thousands of them filling landfill sites across the world.

0

Yeah, I just printed the ATX pinouts and I'll test the psu today. Any ideas on what the best cheap psu is out there? I'll be buying on eBay (used) if it is the issue.

0

Well I use an eye-t 450watt PSU that was only £25 brand new and it's been fine for over 4 years now if that's any help.

0

So I got a chance to test the psu. There were slight anomalies: -12V was -11.88V, +5V was 5.12V, and +12V was 11.31V. These, however, should not have been bad enough to cause issues right?

There were two questionable things, however. First, there was no -5V pin from the psu. I cannot imagine why, especially since the jack on the MOBO did have one. The second item of concern was that the psu would only power on when shorted before being plugged in. In fact, if the green and ground on the ATX cable were shorted after the unit was given 120V feed, the green power light on the back would turn off.

So the question remains, "Is this standard for a psu?" I think not, but before I run on a wild-goose chase for parts, I would like your input. Of course, I will first get my hands on a working psu to test the MOBO before I buy.

By the way, thank you all for helping me on this and sorry Josh if my skirts/posts (or for me I hope it would be a kilt) are a bit long. :-D

0

One more question (sorry). The ATX-2 psu connector seems similar to ATX, but I don't exactly want to burn my house down anytime soon. Can I plug and play with an ATX-2 (or at least test with it) or will ATX-2 ruin my whole day? Hehe- I'm a poet!

0

I would say the PSU is faulty. I am one of the few that can repair them so I know what I am talking about.

+12V was 11.31V = bad.
no -5V pin from the psu = bad.
psu would only power on when shorted before being plugged in = very bad indeed.

0

I would say the PSU is faulty. I am one of the few that can repair them so I know what I am talking about.

+12V was 11.31V = bad.
no -5V pin from the psu = bad.
psu would only power on when shorted before being plugged in = very bad indeed.

Atx 2 should be fine. It should only plug in in the correct position. If you are worried, you can also get an atx2 to atx converter.

0

Yep deffinetly sounds like a gammy PSU, what pin does your motherboard have and what pin is the PSU?

You should be able to pull the big cable out with about 15-20 wires in it.

Then you can count the socket to see if there is 20 or 24 pins. I'm pretty sure an atx-2 will do the job but I wouldn't try it until you check it out a little bit.

As long as you can detach the extra 4 pins and the settings on the back are right for the power outlet (110v UK, 240v US I think) if you are from the UK, check out the Novatech website.

They sell very cheap PSU's infact I think mine was 12-15 pound. It had the same 12v issue as you seem to be having at first but I rang up Novatech customer services and because it's a PSU they will dispatch a new one.

http://novatech.co.uk/novatech/

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.