0

My Dell Inspron 1501 wont start. It was working fine until one morning I tried to insert my wifi divice(USB) the wrong way. No it did not go in all the way but did insert particially; enough to kill the power and it has NOT powered up since. I thought I blew a fuse but dont see one...HELP!

4
Contributors
5
Replies
6
Views
8 Years
Discussion Span
Last Post by ithelp
0

have you check whether your AC adaptor is working or not? and have you tried to removed your battery? if you remove your battery put it back after a few seconds. check if it will help

0

Could be the power module on the board is fried.

Try remove the battery, AC adapter and holding down the power button over 15 seconds to discharge and reset the laptop.
Then connect AC adapter only to power on the laptop again.

Hope this helps!
Bill

0

have you check whether your AC adaptor is working or not? and have you tried to removed your battery? if you remove your battery put it back after a few seconds. check if it will help

Yes, thanx. I have tried both and its still the same. nothing. wont power up, no lights, nothing.

0

As PCTestCard said looks like your power module in your board is causing trouble..is it still under warranty? maybe you can bring that to your manufacturer service center.

0

Are you being able to smell something burnt ? if yes take it to the vendor, if you open it and try to play with laptop, your waranty will be null and void.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.