0

I put my pc to sleep as usual before I went to bed last night. When I woke up and woke up my pc nothing showed up on the monitor...it remained blank.

I've reseated every component, unplugged everything except ram to test if one of my sticks was bad. The mobo didn't beep when I took out all ram...though the mobo has never made a sound the 2 years I've been using this build. I've put the ati 4870 in the other pci-e slot...none of the failure leds lite up in either slot. All fans run, mobo green light is constant. USB peripherals light up (mouse and keyboard).

As for the monitor, I've tested it on my roommates laptop...same thing when I switch to it, remains black. It isn't grey it is black...as if I have completely turned it off even when it is clearly on. Also, the power light flashes when in stanby and when I try to boot the light goes constant.

My guess is that the monitor is dead...and I hope thats the case...but it could also be the motherboard and possibly video card (pretty sure it isn't though).

Please help! This is driving me crazy!

2
Contributors
1
Reply
2
Views
7 Years
Discussion Span
Last Post by wondering_ed
0

Try turning off your PC. Then unplug it from the AVR or UPS or any socket that may be a source of electricity. Then Press and hold the power button for about 30 sec to a minute. Then plug it back all in. Then turn on.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.