Hi all.. I have a Sony Viao VGN- FS315E of a friends.
It seems to have problems booting to the O/S, I get as far as the Sony logo screen, then it freezes, if you leave it for a long time it'll come to a page that asks do I want to use Xp home edition or Windows default, but when you try and press naything the keyboard won't work, I tried plugging in a usb keyboard still no luck!
I read somewhere that it could be a prblem with the Bios/Cmos battery?
Though I dont know how to access this?

Any help would be great!

Doesn't sounds like a bad battery to me. An easy way to tell if it is a hardware or software problem is book to a linux CD or USB.

Ubuntu website gives a pretty detailed walk though on how to create both.

http://www.ubuntu.com/desktop/get-ubuntu/download

If you are able to successfully boot and run Ubuntu off a disc or usb then your hardware is ok and there is a problem with the software and a reinstalling your OS is probably your next step.

If you post the results of the test above I can help you determine the next step.

this sounds like it actually might be a bios issue... the splash screen staying on there for a long time and all. booting to a linux CD is always a good test, so try that first, of course... i don't know if the results will really tell you what you need to know. this could be a failed hard drive or a corrupt bios. replacing the CMOS battery is an easy step if you can get to it, but i doubt that will resolve this. considering that the keyboard won't respond, it's probably the BIOS. have you tried a different USB keyboard? does the vaio have a ps2 hookup for a keyboard (i doubt it but there's always a chance). when the computer first powers on, is there a line of text that tells you how to access the bios (F1, F2, F8 etc)? if there is, try to press that key and see if it responds.

also, try all of your different USB ports for the keyboard. unplug any peripherals that are plugged in.

and finally, if the keyboard is fine to get into the bios, and it just isnt responding when it comes time to select your OS, then problem is probably the hard drive. or it could be memory, i suppose... are there multiple RAM sticks in there? try removing all but 1, and then start up the computer. if the same thing happens, try a different one. try putting them in different slots if you can.