I'm desperate!! last night the main fuse box in the house blew out during a thunder storm - i guess a power surge. This morning none of my 6 USB ports will work. Keep getting a power surge on hub port message, have tried reseting all ports, have uninstalled them, reinstalled them but to no avail.

When I click on the message it says that there is an unknown usb device to reset but there is nothing pluged into my six ports and they still wont work. And this message woont go away I run and emachines tower with Windows XP home SP2

Have I blown something interally or can I rescue my hard ware. Am Desperate, also I am no techi

Just noticed in controla panel/system that is shows 8 usb controllers - is there sometinhg insdie that might be problem? - Thanks

Recommended Answers

I'm desperate!! last night the main fuse box in the house blew out during a thunder storm - i guess a power surge. This morning none of my 6 USB ports will work. Keep getting a power surge on hub port message, have tried reseting all ports, have uninstalled them, …

Jump to Post

sounds like the motherboard is fried

Jump to Post

All 5 Replies

I'm desperate!! last night the main fuse box in the house blew out during a thunder storm - i guess a power surge. This morning none of my 6 USB ports will work. Keep getting a power surge on hub port message, have tried reseting all ports, have uninstalled them, reinstalled them but to no avail.

When I click on the message it says that there is an unknown usb device to reset but there is nothing pluged into my six ports and they still wont work. And this message woont go away I run and emachines tower with Windows XP home SP2

Have I blown something interally or can I rescue my hard ware. Am Desperate, also I am no techi

Just noticed in controla panel/system that is shows 8 usb controllers - is there sometinhg insdie that might be problem? - Thanks

Hi suewright, welcome to Dani web.

Was the computer on at the time that the surge occurred?

I'm guessing that the computer is running from what you have explained, are there any other problems?

sounds like the motherboard is fried

every thing is working fine I have plugged in ordinary mouse and K/B ( mine were USB) internet via router works fine screen ok all software ok slight problem with realtec audio now not working. If I plug in a logitec usb video that wirks!!! But still getting this message and every new usb hard ware i try to plug in does nothing

Realtek ac(7 audio controller is now failing to start. Is it work getting some PCI USB cards and bypassing the internal stuff?

Ta loads

i think its time for a new pc :(

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.