0

Hey people I have just recently purchased an Advent ERT2250 Laptop and the function (fn) key seems to be constantly on. This means i have to hold the fn key down so i am able to use some of the keys on the keyboard properly, if i dont hold the fn key down then other characters appear in its place, for example; the mjkluio keys appear as 0123456 unless fn is held down. I know it's supposed to be the other way around but it seems locked in this state. I have tried a format and put XP on the laptop but its still the same. I have checked the BIOS for any settings on the keyboard but none are listed. It was working fine earlier on and i cant think of anything i've done that would've changed this setting. Is there a certain command that switches the function key on/off like ctrl + alt + ? etc. Any help is more than appreciated.

40
Contributors
39
Replies
101
Views
10 Years
Discussion Span
Last Post by Salbin
0

Huh thats interesting. Have you tried turning it upside down and lightly taping the area to see if it becomes unstuck?

3

Hey people I have just recently purchased an Advent ERT2250 Laptop and the function (fn) key seems to be constantly on. This means i have to hold the fn key down so i am able to use some of the keys on the keyboard properly, if i dont hold the fn key down then other characters appear in its place, for example; the mjkluio keys appear as 0123456 unless fn is held down. I know it's supposed to be the other way around but it seems locked in this state. I have tried a format and put XP on the laptop but its still the same. I have checked the BIOS for any settings on the keyboard but none are listed. It was working fine earlier on and i cant think of anything i've done that would've changed this setting. Is there a certain command that switches the function key on/off like ctrl + alt + ? etc. Any help is more than appreciated.

I have recently had the same problem but have now managed to fix it. Hold the Ctrl and Fn key down together and press also the Ins(Num LK) key. This should revert the keys back as normal. Well it worked for me. Good Luck.

Votes + Comments
than kyou so much
0

Thanks!! I have spent hours tring to find help to clear the active [Fn] key.
I looked in most German sights. Well I have a Sony Vio PCG-SRX51P/B.
Your tip solved my problem:
[Num] (4th key from the top right) then [Fn] (2nd key buttom left) and then [Ctrl] (the Strg 1st Key buttom left) -> all held together.
This reverted the keys back as normal. Short text:
Answer: [Num] [Fn] and [Ctrl] -> all held together.
Well it worked for me. This might help solve your problem.

0

Thanks!! I have spent hours tring to find help to clear the active [Fn] key.
I looked in most German sights. Well I have a Sony Vio PCG-SRX51P/B.
Your tip solved my problem:
[Num] (4th key from the top right) then [Fn] (2nd key buttom left) and then [Ctrl] (the Strg 1st Key buttom left) -> all held together.
This reverted the keys back as normal. Short text:
Answer: [Num] [Fn] and [Ctrl] -> all held together.
Well it worked for me. This might help solve your problem.

This was driving me CRAZY, I reseated my keyboard I'll bet one hundred times trying t fix this, your fix worked! I did have to hold them together for a few seconds for it to work, but Wala!!! I cannot thank you enough!!!!! ~jdk

0

Yes this trick worked even on a mini HP laptop. I had to hold the keys together for a second or two and get the keyboard functioning normally again.

Thanks for your fruitful assistance

0

it works but you dont have to press the control button its just the num lock aka f11 and the fn button in reverses the lock thanxxx

0

Hi!! How do i keep my FN locked so i can have easier access to my functions F1, F2, F3, F4, etc..... i dont want to depend on the FN function in order to access these buttons. I have a dell laptop and i couldnt find any Num Lock key.

0

I tried to hold those keys, but it didn't work. then i pressed those keys seperately. then suddenly I noticed, when the num lock is on, then this problem occurs. but when this is off, then it works normally.

thanks
this was reaaly helpfull

0

if you cant turn it off by hitting the numberlock, you can try to open
the onscreen keyboard and turn it off there.

0

Basicaly num lock was on. Press Fn and num lock key to reverse it.
Thank you very much. It worked.

0

I have recently had the same problem but have now managed to fix it. Hold the Ctrl and Fn key down together and press also the Ins(Num LK) key. This should revert the keys back as normal. Well it worked for me. Good Luck.

thanks ur tip really helped me out i was getting really frustrated with the fn shit

0

Thanks for this shortcut ...its working....I was facing this issue quiet a long time....now recovered my old setup..Thanks for thz guysss...

1

For those who had problems about reversing the fn key function, and do not have the numlk key.. what I did was go to the setup utility(BIOS) and go to configuration settings.. and disabled action key...

This problem occurs to those who have notebook laptops like mine.

To enter BIOS.. just turn on your pc and enter the appropriate key to enter setup.. usually it is esc delete f2 or f12.. then just follow the steps above.

after doing these you can test it by pressing the fn+function keys to know if you had it reversed...

HOPE this helps and sorry for the wrong grammar.

Votes + Comments
worked great!
0

Thanks for the tip! On my particular laptop, it was the Fn key along with the Home (Num Lk) key. I kept trying combinations until I got it right. Thanks again for providing some direction.

0

well i have an dell inspiron mini and i pressed and held fn+insert and it did nothing for me

0

Hey people I have just recently purchased an Advent ERT2250 Laptop and the function (fn) key seems to be constantly on.

shame it's dead, it worked for me.

0

Nothing worked for me (I don't have a NumLk key) until I went to Accessories/Accessiblity/OnScreen Keyboard **and I could SEE the problem there. I had accidentally pushed the NumLk button on the onscreen keyboard. THAT'S what caused the darn Fn key to lock. I actually put up with this bullsh****t for OVER A YEAR. Can you imagine? I looked at all the Help files for my PC and WinXP and it never mentioned this problem. In fact it rarely mentioned the Fn key at ALL. **THANK YOU ALL SO MUCH. I now have a usable keyboard. I used to have to hook up another keyboard to be able to type. Now I won't have to - thank you!!! ** :-)**

Karen

0

I now have a usable keyboard. I used to have to hook up another keyboard to be able to type. Now I won't have to - thank you!!! ** :-) **

Thanks for the feedback, Karen.
Glad you finally got it sorted out! :)

Edited by PhilliePhan

0

can someone help i got a new toshiba laptop for my birthday and i play a game that uses f1-f12 alot and i have to keep holding down the fn key to use them does anyone know how to keep it on or fix it? so i dont have to keep holding the fn key down? if you can it will be really helpful

Cheers.

0

My laptop is Compaq Presario c771US Notebook PC and os is windows vista. It also had the same problem with fn key. As advised in the wall I just switched of the num lock key and the problem was solved.
thanks a lot.....

0

That sounds little weird. I never heard of such a problem before. Thanks for the solution provided. We are working with laptop support. I am sure this info is a new solution to all of us. We can use this solution now onwards.

Edited by JorgeM: Please do not include non-relevant links in your post. Thank you.

0

thankx a ton it works....
turn off the num lock and hold fn and num lock for 5 sec and a pop up box appers and press ok....

0

okayy.. I did that with the locking and unlocking and everything else.. but the problem is that each of my buttons work, except these for the brightness. It's like they don't exist. I tried everything.. and still they don't work.

0

Ref: Advent 4211 - '...Accessories/Accessiblity/OnScreen Keyboard **and I could SEE the problem there...'

Karen, your method worked (onscreen keyboard - switching the 'ctrl' and then the 'nlk' on/off a couple of times). Thank you all for posting the advice. You're life savers one and all.
Regards
Tim

Edited by tallmanjack

0

For my Fujitsu Lifebook, it was just (Fn) + (NumLock) key to turn off Fn key! Thanks guys!

Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.