0

Hi, folks!

Hope you can help me. I did a little searching here, but didn't find any info that seemed to fit exactly what I have going on ...

I have a Toshiba Satellite M35-S320 (yeah, it's old, about 4-5 years old, but I love it.) I am on a long motorcycle trip and plugged it in the other night, but it indicated that the battery was 'critical',despite being plugged in the entire night before and turned off all day long. Worked perfectly otherwise, however...was able to get on the internet briefly, etc. I plugged it in, like usual, but it did not recognize that I'd done so. Still telling me the battery was low. huh? So I check my plugs, try a couple of sockets, still with the same result. I shut down the computer and noted that the charger itself now rattled in a way it didn't used to rattle. So, I think, I shook my charger to death in the saddlebag whle on the bike. No biggie.

Over the weekend, I get another one (a universal one that had a tip
specifically for my make/model of laptop)and plug 'er in. Still no go. The charger lights up and blinks away, but no juice at all. Battery was still 'critical', even after I leave it plugged in for hours. The only difference is now the light indicating that the laptop is plugged in is blinking occasionally. Not regularly, just occasionally. Usually, when it is plugged in, the indicator light stays on steady. Never saw it blink before in the past.

So, folks, any ideas on what's wrong? My hunch is perhaps the battery died a sudden death itself, somehow, especially given that the battery is about 4 y/o. But even then wouldn't it work when plugged in and running from A/C? Or not? I just don't know.


thanks in advance,

Jill

6
Contributors
9
Replies
10
Views
10 Years
Discussion Span
Last Post by natere2ster
0

Hi Jill

Welcome to the site - good to hear of another biker who carts their laptop on it.

There is what I call a design fault in Toshiba Laptops. The socket on the back that you plug the power lead into is purely soldered straight onto motherboard with no physical restraint on it. The joint cracks/breaks and the power does not get to battery.

Try plugging in the power cable and gently wiggle power cable and see if power light on laptop lights up.

The socket can be resoldered onto the board but it requires taking the laptop completely to bits, not easy but can be done.

Denis

0

I have also experienced a similar problems with older NEC computers. The work around was usually: removing the battery and then plugging in the charging cord, or getting a new battery as some of the cells may be dead. Of course as DenisOxon said it could just be the solder. Hope you can work around soon

0

Thanks to you both for your ideas! You've given me some direction to go in!

Jill

0

Hi there,
May I add, Toshiba graciously extended the warranty on certain of their Satellites, including the m35, due to the faulty power socket. There are numerous posts online.
I have sent two such models in for repair. After the initial call (35 minutes), both were returned within 3 days with new boards (I checked)
The other models if memory serves, are the m30 and a70-a75?
Anyhow, support by Tosh, in my experience was great.
Good luck.
BTW, should it turn out yours is not warranteed, it can be successfully repaired for very little. I've done 4 or 5.
Thanks

0

I have the same problem but I don't believe its a problem with the dc jack...it doesn't wiggle nor does the led power come on when moved around (careful when doing this!)

Can i test the battery somehow? What else is there to check if the DC jack issues isn't the culprit? Is there a fuse somewhere on the psu on the motherboard? I guess I can take it part and test on the board to see where the power goes....

0

if you remove the battery ,plug in the power adapter charger ,you laptop should turn on ,if not then maybe something wrong with the power adapter/charger

0

yea i am not sure about this...

will the unit turn on without the battery installed on it? even if its dead i thought that the laptop would turn on without the battery but i seem to remember trying this on another Toshiba satellite, a m35x. so i guess my question is:

will the laptop turn on if you remove the battery or if the battery has no charge?
can anyone test this for me if they have the model i have (m45-s2692) or one close to it?

I agree I think its something with the power on the board but its not the overheat problem nor the loose dc jack issues so i am hoping its the battery croaked.

thanks!

0

I got it working turns out that the DC jack was very dirty (corroded, oxidization, etc)

Used some electronics contact cleaner and wiped it out....

booted right up! my battery life still sucks but it works! now if i can just get my java program to work! LOL

Thanks for all the advice!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.