0

I was working on a friend's Presario 2500 and I think I killed it. It had numerous problems - would not boot with a battery in it, the mouse touchpad did not work, and it seemed as if the A drive could read but not write. I used a usb mouse, reformated the hard drive, reloaded windows xp home, installed some software, and bought a new battery. It had trouble with the new battery - would charge it and then drain it completely very quickly. But it worked - if you kept the battery out and stayed far away from the power cord. Then I tried updating some drivers from Compaq as well as BIOS (the latest version corrected problems with batteries so ...). I downloaded the new BIOS on another computer and loaded it onto a floppy and then put it in the laptop and rebooted. Now it turns on and shows the black screen with Compaq in red but stops there. The fans run but no beeping, no hard drive light flashing etc. Is it now totally dead? Is there anything else left to try? I know enough to be dangerous but am not real proficient.
Thanks,
Evelyn

4
Contributors
6
Replies
7
Views
10 Years
Discussion Span
Last Post by caperjack
0

The more I chew the bigger it gets.
Overall U seem to have a bad board.
Probs. with the A drive indicate a bad controller.
Batteries usually work fine, as long as U DON'T touch both sides at the same time, however briefly. You'll drain half the life out of the batt. before U can let go.
U didn't indicate that you actually reloaded the BIOS.

0

I dont think that I actually did reload BIOS. I put in the disc and restarted and it booted to the Compaq screen and just stays there. So I dont know if BIOS is there or not, if its the old or new, and how to even check since I cant get it past the compaq screen. The battery charges and then drains while it is in the computer - no one touching it. Once it charged fully but only read as 26% charged the next time it charged to 100% and then drained itself completely even though the computer was still on, still plugged in and no-one had touched it. Is there anything to do to try and revive it and see where things stand?

0

Try booting into bios and check the rompaq update and date. Compare them to what you have downloaded. I think your new battery is an old stock and not able to receive enough power to charge.

0

How would I boot into BIOS? I cant get it to do anything at all except show the compaq screen. It doesnt go far enough to get to BIOS. I think the new battery is fine - its the computer screwing the old & new battery up.

0

If the cmos battery is accessible, try to reset it. I think it's the last remedy to be considered. Bios updating is very delicate, once you loaded a wrong bios/rompaq update into it you will have a totally dead pc (corrupted bios). Replacing ROM/BIOS chip is 50-50 chance, what you need is replace the motherboard.

0

doesent sould to me like you flashed the bios,after you booted to the floppy did you run the flash utility from the floppy to copy the ned bios info to the cmos chip.if not then its not likeyly you did flash the bios.did you remove the floppy from the laptop !!
Try hitting the f2 key as you
turn on the computer to get into the bios.the compaq boot screen is after the bios also try hitting tab key to remove the compaq screen

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.