0

I got this blemish t23 IBM Thinkpad Laptop that did not come with a hard drive, a hard drive caddy, RAM, RAM cover, and some other things. I got all the stuff for it and installed WinXP on it. I got all the needed updates and Anti-Virus and everything. It worked fine for a week and then the clock started acting weird. my computer had to be plugged in for the time to advance. if it wasn't plugged in, it would just stay at the same time. someone told me that the problem had to do with the cmos battery. I thought that maybe it had come loose so after i shut my computer down, I took out the cmos battery and put it back in. when i started my computer an error message came up that said: error #0271 check date and time settings. after it displayed this it went to the bios password screen and i entered the only password i knew: the user password which was nothing. it would not let me change any settings so i exited and the same thing happened when i rebooted it. i went home and google-searched "bios password" and found that a few websites said that if i remove the cmos battery for 10-20 min, it would clear the bios password. I did this and now i can't even enter setup as a user and my computer still can't get far enough to load the operating system or anything. I can't unlock the bios at all or view it. I downloaded PCDoctor: a program that said that you save it to a disk and boot from it it will give you the option of changing/removing the bios password. but my computer doesn't get far enough for me to change it to boot from anything. Does anyone know how to help me out?

4
Contributors
13
Replies
16
Views
9 Years
Discussion Span
Last Post by DCarl
0

Firstly, you don't have an option to press a certain key to just ignore the error and continue?

What strikes me as strange is that the time would not advance when running off the battery.

Basically, all the cmos battery does is provide just enough power to hold the settings from the BIOS. It is understandable that everytime you shut down and restart that the time would disappear. Normally though, if you merely soft-reset, the settings are not [usually] discarded. I would guess that there is something else (on top of the battery) causing these symptons.

On some desktops, a wrongly placed jumper sometimes caused this effect. (some older IBMs would still boot when the clear cmos jumper was set, but not retain any bios changes similar to what you are experiencing here)...since this is a laptop, there really aren't any user changeable jumpers...

My first guess would be corruption within the bios...suggestion - flash BIOS, if that were possible.

0

Ok, flash bios... is that possible to do in it's current condition? and one small thing (although it's probably of no help) the time would stop everytime i put my computer in standby mode and would only resume when i brought it out of standby. (i never got a chance to test running it by just the battery).

(thanks 4 ur help so far)

0

Ahhh...ok, that clarifies it. Its your CMOS battery. When in Standby/Hibernation, the clock is kept by the cmos battery, so if that is dead, then obviously it won't "advance' the time(it won't reset because there is still power to the laptop).

Pop open the top of the laptop...on the left side, near the PCMCIA slot, there should be a small black rectangle thing with a pair of wires that plug into the motherboard - that should be your cmos battery. take that out and visit your local repair shop...they may have one kicking around in one of their spare parts bins.

0

i've got another cmos battery (a good one) in a t22 laptop that i keep 4 parts, if i take it out of there and put it in, would that solve the whole deal about not knowing the password to setup 4 it to successfully boot? would a new battery not have that time/date error? if i could get it to boot successfully just once, i could use the program i bought (PCDoctor) to change/disable the setup password.


my parts laptop has some issues with the motherboard (shorts and graphics problems) but at least it boots up. right now the setup password is disabled. if i took the battery out, would it go to being enabled?


i just bought a brandnew cmos battery off of ebay but it will be a couple weeks b4 i can put it in my laptop. i have the other laptop with me. would i be able to get away with using the cmos in it till the new one arrives?

0

It *may* allow you to enter the BIOS(no guarentees)...just swap the battery and find out :-)

0

I switched the cmos batteries and the same error comes up when i turn my laptop on. do you (or anyone else for that matter) know if there are any keys you can press that would make it ignore the check date and time error? I really really need to get this working, i use it for school. is there anything i can do to make it boot successfuly?! i know on some laptops there are keys you can press when starting up to make it do certain things like restart and go to setup. are there any for skipping or ignoring errors?

0

On a number of Thinkpads, your can enter without a BIOS supervisor password if you hold down the F1 key during bootup. No guarantees, but its worth a try.

0

i tried holding down F1 key on boot up and it didn't work. it will only work on a computer that has the supervisor password already disabled.

i really could use any advice that's available right now.
any suggestions!?

0

i could really really use some help right now. is there any way that i could maybe read the security chip with another computer and get the password that way?

0

Try a BIOS upgrade. IBMs will usually boot from the floppy when it is inserted even if there is an error preventing it from booting normally...worth a try.

0

thanks 4 all ur suggestions and advice on this issue. it really helped out a lot.
i never was able to try to update the bios w/ a floppy but over the weekend i found this site:

http://sodoityourself.com/hacking-ibm-thinkpad-bios-password/

it told me how to easily read my password directly from the security chip and i was able to enter the setup and disable the password. the directions said to sodder the wires to the chip but i just got my brother to help me hold the wires in place (i wasn't going to try to soder a wire to something that had less than 1/2 millimeter space on each side). i spent a total of $10 for parts (including shipping) and now my laptop is up and running. i might be able to post a picture of the little gizmo i built in a week or so.

thanks once again for all ur help! :-)

0

i get a problem when starting windows...bios error & i notice the date is about 5 yrs old ?? do i just need to change the battery?? Please help.

0

i get a problem when starting windows...bios error & i notice the date is about 5 yrs old ?? do i just need to change the battery?? Please help.

It sounds like you have a desktop machine and need to replace the cmos battery. It is silver in colour and between a nickel and quarter (US) in size. These are very inexpensive. Take the current one with you, though, to make sure you get a comparable replacement. When you put in the new one, you will need to set the time and date once.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.