0

Hi guys I'm the newbie here. I've searched and read a couple of posts of people with related issues but nothing quite the same as me. Theres a bit of history with this comp so let me begin.

This laptop has been great to me but its been starting to heat up. Well last week it went into SUPER SLOW mode. Even to the point where it doesn't want to do anything. After looking around and seeing how this model has been plauged with heating issues I wouldn't doubt if the Motherboard took a dump. Today I just received a new fan and heatsink from Dell. I do the simple install being very careful not to damage anything. After I was done I went ahead and put everything back together. When I start it up for the first time in about a week, the computer turns on and the fan starts working but I get no display. Only black. When I hook up an external monitor, I still get no display from the external. The comp SEEMS to be ok except for the display. I've read that a new video card might do the trick but I would like to know if this issue may also be related to the motherboard before i start dumping money into new parts.

Thanks,
Khem

2
Contributors
2
Replies
3
Views
9 Years
Discussion Span
Last Post by Khemicol
0

I've been in this game for more than 20 years and I know when "dumping money" is dumping money for poor return.

If you can invest in a new laptop, do so. The HDD can be slaved in a USB enclosure and you'll lose no data.

I know it's not what you want to hear. But face it, first the heat problem, then the display, then your time, then the hassle .....

0

How can I go about doing that? I wouldn't know where to begin.

Thanks again.
Khem

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.