OS is Fedora Core 1
Hardware is ATI TV Wonder VE
Software is tvtime 0.9.12
The Goal: To allow all the users of the machine (myself and two other members of the household) to watch tv without having to a) be root, or b) execute a separate command after tvtime exits to kill the audio.

(Snipped) Contents of /etc/modules.conf:
options bttv card=64
options tuner type=2
post-install bttv insmod tuner
post-remove bttv /sbin/rmmod -r bttv

I have the same issue as this post:

And have implemented a similar fix. This is the contents of the /usr/bin/run-tvtime file:
/sbin/modprobe -r bttv

The problem is that I dont want to run the tvtime app as root, and when I run it as a regular user, I get issues with modprobe. The run-tvtime script outputs on exit:
Thank you for using tvtime.
bttv: Operation not permitted
bttv: Device or resource busy

So the question is: how do I kill the audio as a non-root user?

So the question is: how do I kill the audio as a non-root user?

Did you set the proper permissions as the other post explained? Have you tried doing chattr on the audio device (making it executable by everyone)?

You could also install and configure sudo so every user in group wheel can run commands without a password using sudo command (just make sure the users actually belong to group wheel.)

I've never came across this issue, so I don't have a working fix for it (I also don't use RedHat/Fedora) so I don't know all the specifics regarding this, but maybe one of these suggestions helps...

Adding the users to the wheel group is the only thing I havent tried, and should only use that as a last resort, as I dont want to allow an accidental: $ sudo rm -Rf

Thanks for the reply.

Can you specify 'modprobe -r bttv' or just 'modprobe' though in the sudoers file? If you can have any user in a 'tvusers' group to be able to 'modprobe -r bttv' using sudo, that would be your safest bet. (I think.) I'm sure you wouldn't want to have everyone be able to run 'modprobe <any module>'. For obvious reasons. :) Even if you are the only user of the machine, it just isn't good practice.

This article has been dead for over six months. Start a new discussion instead.